LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-30-2010, 04:53 PM   #1
deltrem
Member
 
Registered: Dec 2010
Posts: 36

Rep: Reputation: 0
I got in dependency hell...


I'm using pclinuxos and trying to install empathy.

The version in repository blinks (opens, right after, closes).

The newest version is compiling from source, many dependencies, can't be installed automatically.

The previous version:

- rpm -ivh rpmfilename is many dependencies too that can't be installed automatically too

I tried gui:

- installing apturl, clicking the rpm file link, opening it with apturl, installation gui alerts error message
- opening the rpm file with Synaptic doesn't work
- opening the rpm file with /usr/bin/apt-get doesn't work

If I add the previous rpm repository to Synaptic, what will it do to the current?

If I apt-cache add previousname.rpm, what will Synaptic and apt do to the current and what will the apt-get install previousname (.rpm? no .rpm?) be?

Last edited by deltrem; 12-30-2010 at 04:59 PM.
 
Old 12-30-2010, 06:41 PM   #2
deltrem
Member
 
Registered: Dec 2010
Posts: 36

Original Poster
Rep: Reputation: 0
I found the previous version at:http://ftp.riken.go.jp/archives/Linu...010/RPMS.main/ So I added http://ftp.riken.go.jp/archives/Linux/pclinuxos/apt/ with pclinuxos/2010 and main. Then, I opened Synaptic, updated the package list, but there was only the newest version, so Force Version was grayed.

Finally, I tried:
su
apt-get update
apt-get install empathy=2.30.1-1pclos2010

E: Version ='2.30.1-1' for 'empathy' was not found
 
Old 01-06-2011, 09:04 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,393

Rep: Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607
Synaptic > "Refresh". Or : # apt-get update :

Then the available 'empathy' is now version '2.32.1'.
( empathy-2.32.1-1pclos2010 ).

But the "ftp.riken.go.jp/archives/....." is an "archive",
not a repo, that gets updated.

The two lines currently used in my /etc/apt/sources.list are :
Code:
rpm http://ftp.heanet.ie/pub/pclinuxos/apt/ pclinuxos/2010 main updates nonfree games kde4 

rpm http://ftp.klid.dk/ftp/pclinuxos/apt/ pclinuxos/2010 main updates nonfree games kde4
..
 
Old 02-01-2011, 12:23 PM   #4
deltrem
Member
 
Registered: Dec 2010
Posts: 36

Original Poster
Rep: Reputation: 0
I know how to add an archive to Synaptic, but how to add a repository? Also, I was trying to install a older version, because the current in repository wasn't working and the newest was source. How to install the older version?

Quote:
Originally Posted by knudfl View Post
Synaptic > "Refresh". Or : # apt-get update :

Then the available 'empathy' is now version '2.32.1'.
( empathy-2.32.1-1pclos2010 ).

But the "ftp.riken.go.jp/archives/....." is an "archive",
not a repo, that gets updated.

The two lines currently used in my /etc/apt/sources.list are :
Code:
rpm http://ftp.heanet.ie/pub/pclinuxos/apt/ pclinuxos/2010 main updates nonfree games kde4 

rpm http://ftp.klid.dk/ftp/pclinuxos/apt/ pclinuxos/2010 main updates nonfree games kde4
..

Last edited by deltrem; 02-01-2011 at 12:26 PM.
 
Old 02-01-2011, 02:08 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,393

Rep: Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607
The new ( 2010 ) repo = /etc/apt/sources.list is attached here, post #3

http://www.linuxquestions.org/questi...tory-855319/#3


Old packages : http://ftp.uwsg.iu.edu/array2/linux/sam/repo/

..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What dependency hell?? Chikne Slackware 69 02-10-2007 08:20 AM
dependency hell conanm4 SUSE / openSUSE 3 08-21-2006 01:53 PM
dependency hell riseringseeker Linux - Newbie 3 09-22-2004 02:57 PM
Dependency Hell :-( AMMullan Linux - Software 5 03-27-2004 11:51 PM
Dependency Hell Time Lord Mandriva 2 09-09-2003 04:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration