LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-03-2012, 10:38 AM   #1
Akash007
LQ Newbie
 
Registered: Apr 2012
Posts: 4

Rep: Reputation: Disabled
I cannot install a gtypist because it says dependency is not satisfiable.


i am working on ubuntu 11.04 and i am getting a problem while installing gtypist from terminal and even from ubuntu software center. the file is .tar.gz and another is .deb
from terminal i get the reply as "unable to locate package".
even if i uncompress it and then install, it says "dependency is not satisfiable".
 
Old 08-03-2012, 12:47 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2018 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,125

Rep: Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491
Why not use the Ubuntu package ?

sudo apt-get update && sudo apt-get install gtypist

http://packages.ubuntu.com/natty/gtypist


.
 
Old 08-04-2012, 01:21 PM   #3
Akash007
LQ Newbie
 
Registered: Apr 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
That's not helping and now it's saying "Unmet dependencies"
 
Old 08-04-2012, 10:18 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 14,256
Blog Entries: 24

Rep: Reputation: 3889Reputation: 3889Reputation: 3889Reputation: 3889Reputation: 3889Reputation: 3889Reputation: 3889Reputation: 3889Reputation: 3889Reputation: 3889Reputation: 3889
Try running the program from a terminal. That should throw an error message listing missing dependencies.

Note that this issue may cascade; satisfying one dependency may result in identifying others before the program is happy.
 
Old 08-05-2012, 05:13 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2018 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,125

Rep: Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491
There can actually only be one reason, I think, that the command
"sudo apt-get update && sudo apt-get install gtypist" isn't working:
'An /etc/apt/sources.list' with "something" added.

Please show the reply from the command : cat /etc/apt/sources.list


P.S. : gtypist dependencies are : 1) libncurses5 ( Always installed )
2) fortune-mod (+ librecode0 ).


.
 
Old 08-08-2012, 12:24 PM   #6
Akash007
LQ Newbie
 
Registered: Apr 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Do I need fortune-mod & librecode0 seperately ?
because while installing fortune-mod, terminal says "Dependency is not satisfiable".
 
Old 08-08-2012, 12:33 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2018 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,125

Rep: Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491
Something is wrong with your "sources.list",
when you can't install a simple application with apt*

Please show the reply from the command : cat /etc/apt/sources.list


If you insist installing things manually :
1) librecode0 http://packages.ubuntu.com/natty/librecode0
2) fortune-mod http://packages.ubuntu.com/natty/fortune-mod
3) gtypist

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wget: 416 Requested Range Not Satisfiable samrat_rao Linux - Server 3 02-08-2011 02:20 PM
Dependency Not Satisfiable Error RP722 Ubuntu 1 07-14-2009 01:35 AM
Dependency is not satisfiable: libcairomm-1.0-1 taylorkh Linux - Software 5 02-18-2009 04:06 PM
Error When Installing Beryl "Dependency is not satisfiable" Heliodor Felpipe Ubuntu 4 02-02-2008 07:17 AM
download skype on ubuntu (Dependency is not satisfiable: libasound2) Coxynelle Linux - Software 1 01-05-2008 09:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration