-   Linux - Software (
-   -   I cannot format my ext4 usb memory (

miros84 08-13-2009 05:23 PM

I cannot format my ext4 usb memory
I tried to install fedora in my usb memory and I had to make 2 particions in my 4Gb usb memory, not something went wrong and the instalations stoped. That is no problem for me, but now, my usb memory is parted in 2 ones and it is formated in ext4 :mad:
I want to recover my usb memory as I had it before, formated in fat32, but I dont know how to do it. I have debian lenny and Fedora 11 as OS working.
Can you tell me some tool, so I can recover my usb memory? Any advice?

When I type blkid I can see only one part
I should see sdb1, but I dont see it

mushroomboy 08-13-2009 05:24 PM


miros84 08-13-2009 05:35 PM

Seems to be ok with this program, but I cannot format to fat32...

repo 08-13-2009 05:38 PM

you need to unmount the drive first in gparted, before you can format

linus72 08-13-2009 05:41 PM

also, you can install fedora 11 to usb without partitioning or making ext4 partition

Use liveusb-creator avail in add&remove software
liveusb-creator will install fed11 to usb and make persistent overlay of whatever size
usb must be fat32

miros84 08-14-2009 05:22 AM

Oo, thank you very much. I didnot know that.

miros84 08-14-2009 03:11 PM

I tried to format to fat32 and I didnot can.
I unmount the usb memory and then I could format only to ext3, ext4 but I cannot format to fat32. I had to go to windows xp to format it to fat32, but I dont want to go to windows xp. I want to do it on linux. Any idea?

repo 08-14-2009 03:21 PM


mkfs -t vfat /dev/your_usb
make sure to use "fdisk -l" to get the correct device.

All times are GMT -5. The time now is 10:54 AM.