LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   i can not record my voice. (https://www.linuxquestions.org/questions/linux-software-2/i-can-not-record-my-voice-479798/)

bruse 09-02-2006 02:09 PM

i can not record my voice.
 
Hi All,

Running Debian 3.1r2 with kernel 2.6.15 and have proble mrecording my voice in my headphone's microphone.

Intel motherboard with "snd-hda-intel" driver.Also sound works good.

My headphones microphone recorder is working well since I have tested in windows too..working good in windows.

And i have not altered any hardware from out of windows works.I directly switched to debian from windows;to check recording working or not in debian.so there is absolutly software or debian setup problem no way to hardware problem..

well,here r my problem goes.

First look at my alsamixer screenshot here,

http://rootshell.be/~navaladi/index.html

I think they are strange problems.

Also i have very doubt,to chose a recording device either Mic, or Line In or Igain..I don't know pls guide me here.


I have used arecord to record my voice..it recorded but while play it in mplayer ...i don't hear my voice.


Code:


debian:~# aumix -q
vol 100, 100
line 100, 100, R
mic 100, 100, P
cd 100, 100, P
pcm2 100, 100
igain 100, 100
debian:~#


Code:

debian:~# amixer
Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'Front',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'Front Mic',0
  Capabilities: pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Mono: Capture [off]
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'Surround',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'Center',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'LFE',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 23
  Mono: Capture [on]
  Front Left: Playback 23 [100%] [on]
  Front Right: Playback 23 [100%] [on]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 23
  Mono: Capture [off]
  Front Left: Playback 23 [100%] [on]
  Front Right: Playback 23 [100%] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 23
  Mono: Capture [off]
  Front Left: Playback 23 [100%] [on]
  Front Right: Playback 23 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 13
  Front Left: Capture 13 [100%] [on]
  Front Right: Capture 13 [100%] [on]
Simple mixer control 'Mixer',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Channel Mode',0
  Capabilities:
  Mono:
debian:~#


Thanks

HappyTux 09-02-2006 02:35 PM

Well this shows the mic capture is off so in the alsamixer highlight the mic setting and hit the m key to unmute and perhaps see if there is a volume raise possible.

Code:

Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 23
  Mono: Capture [off]
  Front Left: Playback 23 [100%] [on]
  Front Right: Playback 23 [100%] [on]


bruse 09-02-2006 10:17 PM

I have already unmuted everthing & checked.Also set a volume to 100%

also does Mic is the one which recording my voice?

Have u seen that alsamixer screenshots?

this this how i recorded my voice but it did not work.


Code:

debian:~# arecord ff.wav
Recording WAVE 'ff.wav' : Unsigned 8 bit, Rate 8000 Hz, Mono
Aborted by signal Interrupt...
debian:~# mplayer ff.wav
MPlayer 1.0pre8-3.3.5 (C) 2000-2006 MPlayer Team
CPU:              Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 4, Stepping: 9)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2


Playing ff.wav.
Audio file file format detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 8000 Hz, 1 ch, u8, 64.0 kbit/100.00% (ratio: 8000->8000)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [oss] 8000Hz 1ch u8 (1 bytes per sample)
Video: no video
Starting playback...
A:  7.6 (07.5) of 7.0 (07.0)  0.0%

Exiting... (End of file)
debian:~#

Also i can not set my volume to 100% see below.


Code:

debian:~# amixer sset "Front Mic",0 100%,100%
Simple mixer control 'Front Mic',0
  Capabilities: pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Mono: Capture [off]
  Front Left: Playback [on]
  Front Right: Playback [on]
debian:~#

 
debian:~#
amixer sset "Front Mic",0 100%,100% unmute
Simple mixer control 'Front Mic',0
  Capabilities: pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Mono: Capture [off]
  Front Left: Playback [on]
  Front Right: Playback [on]
debian:~#

Also i have set unmute but momo capture is still [off] why?

And i manually set unmute to alsamixer by pressing 'm'.

what goes wrong?


All times are GMT -5. The time now is 08:32 AM.