LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-22-2003, 12:13 PM   #1
Boogieman
Member
 
Registered: Sep 2003
Distribution: Debian GNU/Linux
Posts: 35

Rep: Reputation: 15
i can't mount my CD-ROM


I have red hat 9 and i got the nest problem:

when i type

$ mount /mnt/cdrom
mount: /dev/cdrom is not a valid block device

here is my /etc/fstab
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

more info
$ dmesg
...
hdc: ???????????????????????????????????????, ATAPI UNKNOWN (type 31) drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
...
ide-floppy driver 0.99.newide
hdc: driver not present
ide-floppy driver 0.99.newide
hdc: driver not present
ide-floppy driver 0.99.newide
hdc: driver not present
ide-floppy driver 0.99.newide
hdc: driver not present

can't solve this problem so please help me!

thank's
 
Old 11-22-2003, 01:53 PM   #2
shassouneh
Member
 
Registered: Apr 2001
Location: Cheney, WA
Distribution: SuSE Linux Professional 9.2
Posts: 556

Rep: Reputation: 30
This is normal behaviour.
You don't seem to have an entry for your CD ROM drive in your fstab file.
There should be an entry that is SIMILAR to this line

/dev/hdc /mnt/cdrom iso9660 noauto

also, make sure that the directory /mnt/cdrom exists before adding the line above.

You may have to edit the line I gave you above, as it is just for example.
 
Old 11-22-2003, 03:11 PM   #3
Boogieman
Member
 
Registered: Sep 2003
Distribution: Debian GNU/Linux
Posts: 35

Original Poster
Rep: Reputation: 15
if i add this line

/dev/hdc /mnt/cdrom iso9660 noauto,user 0 0

and i type

$ mount /mnt/cdrom
mount: /dev/hdc is not a valid block device

so i don't know what to do man....
 
Old 11-23-2003, 12:37 AM   #4
shassouneh
Member
 
Registered: Apr 2001
Location: Cheney, WA
Distribution: SuSE Linux Professional 9.2
Posts: 556

Rep: Reputation: 30
Is your CD ROm connected by IDE or SCSI (trust me it makes a difference).
Also, make sure that your cd rom is really at /dev/hdc. You can Use YaST's hardward tools to find out where the CDROM actually resides.
 
Old 11-23-2003, 12:07 PM   #5
Boogieman
Member
 
Registered: Sep 2003
Distribution: Debian GNU/Linux
Posts: 35

Original Poster
Rep: Reputation: 15
where i find this YAST tools that you talk about???
 
Old 11-23-2003, 12:09 PM   #6
shassouneh
Member
 
Registered: Apr 2001
Location: Cheney, WA
Distribution: SuSE Linux Professional 9.2
Posts: 556

Rep: Reputation: 30
oh shoot sorry. I forgot you're on redhat. My bad.

Sorry
 
Old 11-23-2003, 12:19 PM   #7
Boogieman
Member
 
Registered: Sep 2003
Distribution: Debian GNU/Linux
Posts: 35

Original Poster
Rep: Reputation: 15
what??' .. there is nothing i can do ???
 
Old 11-23-2003, 12:22 PM   #8
shassouneh
Member
 
Registered: Apr 2001
Location: Cheney, WA
Distribution: SuSE Linux Professional 9.2
Posts: 556

Rep: Reputation: 30
Well no. There is. The first step would be to find out exactly where your CD ROM device is recognized. I mean is it /dev/hdc or something else?

As a first step, are you sure the CD ROM device is even picked up? Does it work under Windows? Does your BIOS show that it recognizes it when you boot up?

I know these questions seem very obvious and perhaps dumb, but if the answer to any of them is NO then your problem might be hardware (or detection).
 
Old 11-25-2003, 10:37 AM   #9
satishchowdhary
LQ Newbie
 
Registered: Nov 2003
Location: hyderabad
Posts: 6

Rep: Reputation: 0
make sure which type of block device is that and upadte ur /etc/fstab file using the following line

/dev/hdX /mnt/cdrom iso9660 noauto/auto

note: where X is ur raw device name and u have to sue noauto or auto only auto is for auto mounting ur cdrom at the time of booting and noauto meens u nave to mount

if u select noauto enter the following line at $

mount /dev/hdX /mnt/cdrom
note:---------- Dont insert X blindly u definate get the raw devie name at the time before linux is going to up and asking for the interactive mode option

other wise it is a hardware problem and a chance that perticluar user dont have permissions better first chekout cdrom is mounting under # or not

hope ..... helpful

satishchowdhary
 
Old 11-25-2003, 12:36 PM   #10
michaelk
Moderator
 
Registered: Aug 2002
Posts: 16,336

Rep: Reputation: 1907Reputation: 1907Reputation: 1907Reputation: 1907Reputation: 1907Reputation: 1907Reputation: 1907Reputation: 1907Reputation: 1907Reputation: 1907Reputation: 1907
hdc: ???????????????????????????????????????, ATAPI UNKNOWN (type 31) drive


I assume that the drive is connected to the 2nd controller master i.e hdc?
And I assume the drive has been working in the past and this is a recent problem? I would say that kudzu deleted the entry from your /etc/fstab file because it didn't detect the drive at bootup. It looks like its dead especially since dmesg reported problems.
 
Old 11-25-2003, 03:44 PM   #11
Boogieman
Member
 
Registered: Sep 2003
Distribution: Debian GNU/Linux
Posts: 35

Original Poster
Rep: Reputation: 15
death???? ... it won't work any more?????
 
Old 11-28-2003, 04:21 AM   #12
shassouneh
Member
 
Registered: Apr 2001
Location: Cheney, WA
Distribution: SuSE Linux Professional 9.2
Posts: 556

Rep: Reputation: 30
Quote:
Originally posted by shassouneh
Well no. There is. The first step would be to find out exactly where your CD ROM device is recognized. I mean is it /dev/hdc or something else?

As a first step, are you sure the CD ROM device is even picked up? Does it work under Windows? Does your BIOS show that it recognizes it when you boot up?

I know these questions seem very obvious and perhaps dumb, but if the answer to any of them is NO then your problem might be hardware (or detection).
You have not answered the bolded or Italicized questions above. They are CRITICAL in finding out whether your problem is hardware-based or software-configuration based!

Last edited by shassouneh; 11-28-2003 at 04:23 AM.
 
Old 11-28-2003, 06:52 PM   #13
Boogieman
Member
 
Registered: Sep 2003
Distribution: Debian GNU/Linux
Posts: 35

Original Poster
Rep: Reputation: 15
yes, it work's under windows ...
 
Old 11-28-2003, 10:25 PM   #14
shassouneh
Member
 
Registered: Apr 2001
Location: Cheney, WA
Distribution: SuSE Linux Professional 9.2
Posts: 556

Rep: Reputation: 30
OK we at least now its not a software problem. Again, I know its obvious but sometimes the obvious can bite!

One thing you can try I suppose is to unplug thje drive completely so that the next time you boot, you can run the otols that come with redhat to delete its entry in fstab. Then you plug it back in and run these tools agaion to see if redhat can automatically pick it up.

Also, you can try putting it on a different channel/location
 
Old 11-28-2003, 11:14 PM   #15
satishchowdhary
LQ Newbie
 
Registered: Nov 2003
Location: hyderabad
Posts: 6

Rep: Reputation: 0
hope u have a kudzu hardaware detection tool

first unplug the device and start the linux box at the time of booting kudzu hardware detection tool inform you to about unplugedd one if that perticluar cdrom is supported by ur linux redhat 9 if u get the message related to kudzu hardware detection tool select remove configuration and boot ur system normally after system is up shutdown it and plug the cdrom device and agarin restart ur linux box agarin kudzu will display u about ur new hardware i.e cd rom(if ur cdrom is supported hardware for redhat9). at this time select configure it will automatically detect your cdrom and configures it

at this time u can use ur cd rom by mounting it in the process what i have said in earlier u can use it.

otherwise ur cdrom drive is not compatable for redhat 9. what ur cdrom name and series

hope... helpful
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cd-rom and dvd-rom drives won't mount... :-( Ausar Linux - Newbie 12 09-01-2004 03:51 PM
Multiple cd-rom icons from one cd-rom mount CEG Linux - General 5 02-04-2004 08:04 PM
Mount the CD rom ust Linux - Software 1 10-27-2003 06:17 AM
Mount the CD rom ust Linux - Software 3 09-16-2003 10:00 PM
Can Not Mount CD-ROM HowdyZBird Linux - Hardware 1 08-11-2003 09:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration