LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-30-2007, 04:00 PM   #1
Agresvig
LQ Newbie
 
Registered: May 2007
Posts: 6

Rep: Reputation: 0
I'm having some trouble setting up Eclipse


Hi guys.

I just installed Eclipse Java (Europa Edition) on my newly installed OCLinuxOS 07 platform.

I made a simple Hello World test program, but I made it inside a package; edu.du.cs.comp3351.p1. The class is called HelloWorld. The directory structure under my Eclipse workspace directory is then /src/edu/du/cs/comp3351/p1/, and in there is HelloWorld.class and HelloWorld.java.

Here is the code in HelloWorld.class:
Code:
package edu.du.cs.comp3351.p1;
public class HelloWorld {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		System.out.println("Hello World!");

	}
}
It looks fine (at least to me!?) but when I run it in eclipse, I get the error
"Selection does not contain a main type."

Anyone have a clue what I've messed up?

Thanks!
 
Old 08-31-2007, 10:28 AM   #2
Pearlseattle
Member
 
Registered: Aug 2007
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 995

Rep: Reputation: 130Reputation: 130
I think you're messing up things. Eclipse Europa is for C/C++. If you want to program Java you'll have to download and install the other Eclipse package, not "Europa".
 
Old 09-08-2007, 04:54 AM   #3
traene
Member
 
Registered: Jan 2005
Distribution: Archlinux, Debian, Centos
Posts: 219

Rep: Reputation: 33
I guess it should work with eclipse europa. You may have set up the Java builder and stuff. Did you solve it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble running Eclipse carlyno Debian 3 04-03-2007 05:48 AM
LXer: Netbeans attempts to eclipse Eclipse LXer Syndicated Linux News 0 04-17-2006 09:54 PM
Trouble setting up Daniel8802 Mandriva 14 09-06-2005 09:04 PM
Setting java classes source in Eclipse eantoranz Programming 2 07-07-2005 12:17 PM
Setting up Eclipse 3.0 on slack 9.1 pgrimes Linux - Software 2 07-29-2004 04:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration