-   Linux - Software (
-   -   Huh!? Slow scrolling all of a sudden!? (

voyciz 09-15-2004 01:47 AM

Huh!? Slow scrolling all of a sudden!?
One day I did something (apparently) foolish. I tried to open a fifo file in a text editor. Was just messing around, I'm still a newbie. Well this caused everything to freeze up, so I had to kill the power. When I tried to boot up again, it froze when loading the kernel. So I then booted with the rescue disk and fscked all of my partitions. Problem fixed, loaded up fine. Everything was good...or so I thought. For some strange reason, when trying to use the backspace key, the delete key, any of the arrows, or paging with 'less', it is incredibly slow. This is everywhere: in the console, in aterm, even in the textbox I'm typing in now. This is very annoying, can it be fixed?

voyciz 09-20-2004 05:42 PM

I still cannot find an answer, but I did notice something interesting. In my XF86Config file, the auto repeat delay is set to 500, and the repeat rate is 5. But when I start X, the auto repeat delay is 660 and the repeat rate is 25. Maybe the kernel itself got screwed up somehow and overrides this setting? I really have no clue at all, but since I can't find any help on this one, maybe I'll try recompiling the kernel. Good thing I saved that config file! Well I'll report back here once I've tried it.

voyciz 09-20-2004 06:06 PM

Tried it, and it worked...sorta. It was back to it's normal speed at the console right after I started the computer up. When I went into X, it was slow again, with different settings from the ones in the config file. Then when I quit X and was back at the console, it was slow there too. Damn.

voyciz 09-25-2004 03:33 PM

Found the answer to my problem! I commented out the "AutoRepeat" option in my XF86Config file, and it's back to normal! :) Now it works even when I exit X, too. Strange, but whatever, fixed now.

All times are GMT -5. The time now is 12:45 PM.