-   Linux - Software (
-   -   "hub.c : connect-debounce failed, port 1 disabled " (

slk 10-16-2003 08:09 AM

"hub.c : connect-debounce failed, port 1 disabled "
hub.c : "connect-debounce failed, port 1 disabled" is getting when tried to connect to USB device. Because of what this msg is displaying, anybody has overcome this, Plz help me.

jimieee 09-20-2009 11:26 AM

Hi, I know this is a bit a late, but when you put this error in Google it's one of the first to appear - so I thought this might be useful for other users.

I've just had the same error when a Windows user brought me his "broken" digital camera. I plugged into my own laptop and got the error described.

In my case the fix was to change the USB cable for a new one and everything worked normally again.

erics_acvw 10-02-2009 02:51 AM

Yeah, a bit late but the same thing brought me here too. I was restoring a windoze machine using Acronis True Image and got the "hub.c : connect-debounce failed, port 1 disabled" error and True Image would stop. I disabled the USB controller in the BIOS, True Image then restored the image without flaw and I re-enabled the USB controller once again.

luminarycrush 11-10-2009 10:37 AM

This is an old bug which still exists and has not been fixed for at least 5 years. I posted recently here about it:

All times are GMT -5. The time now is 03:31 PM.