LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   httpd dead but subsys locked (https://www.linuxquestions.org/questions/linux-software-2/httpd-dead-but-subsys-locked-338834/)

paleogryph 06-30-2005 03:44 PM

httpd dead but subsys locked
 
FC1

I ran nessus against my webserver and found out it was 'vulnerable' because it had apache 2.0.50. So I got the fc1 rpm for 2.0.51, stopped httpd, and upgraded it via:

"rpm -Uv httpd-2.0.51-1.1.i386.rpm"

It appeared to update fine and a "rpm -qi" told me that indeed it was version 2.0.51.

I ran "./service httpd start" and I get:
"httpd dead but subsys locked"

So I rm -f /var/lock/subsys/httpd, restart, check /var/log/messages and it shows that httpd started. But I notice that none of the httpd services/daemons are there in ps... A ./service httpd status again shows:
"httpd dead but subsys locked"

If I rm that lock file and try to start httpd it says it starts but a status gives the same error and its not really running?

paleogryph 06-30-2005 03:54 PM

nevermind...
 
Ok, I goofed and didn't look far enough.
I found this:
http://www.linuxquestions.org/questi...04/09/2/215355

I commented it out and now it works fine.

So whats the problem with:
#LoadModule unique_id_module modules/mod_unique_id.so
???

m_runwal 11-11-2009 11:09 PM

I don't have that line httpd.conf
 
Recently I have installed fedora11 and I am getting same error. but I did't find the module in httpd.conf, which you have said.
Will you please help me in this ?

loadedmind 05-18-2016 10:37 AM

Any chance you could update the linuxquestions.org URL? This forum is being referenced from another stackexchange article and the fix was said to have existed within this thread.


All times are GMT -5. The time now is 03:10 PM.