-   Linux - Software (
-   -   hplip not showing up in CUPS (

walterbyrd 04-15-2006 05:32 PM

hplip not showing up in CUPS
Correct me if I'm wrong.

If I install hplip and hplip-data with apt-get install. Then go the localhost:631, printer, add printer. I should see a a list of printer makes under "Model/Driver" those makes include: Raw, Dymo, Epson, HP, Zebra, etc.

And, if I have HPLIP installed, I should see that under the list Model/Drivers as well. Should I not?

comprookie2000 04-15-2006 05:53 PM

Debian should have restarted cups, if not you may need to.
Once you select HP, then your printer,you should see a bunch of choices for drivers with (I Think)
HPLIP as an option. You will need ppds installed but apt should have pulled that in.

walterbyrd 04-15-2006 07:04 PM

I restarted my system, but it didn't help. I still don't see HPLIP. Under Model/Driver I see a list like this:


I think HPLIP *should* be on that list, but it's not.

When I do a whereis on my system I get this:

# whereis hplip
hplip: /usr/lib/hplip /usr/share/hplip

So, HPLIP is *there* but it won't show up in CUPS. I have tried uninstalling and reinstalling both hplip and CUPS; many times. It just won't work.

comprookie2000 04-15-2006 07:16 PM

Keep going and select HP.
What happens?

walterbyrd 04-15-2006 07:39 PM

If I just select HP, I only have a about six printers listed. I should have a selection that reads HP (HPLIP) and that selection should have *way* more printers listed.

I have another linux box named "Spruce" that I run in parallel to this box, named "Aspen" (same version of debian, same file stucture, etc). I installed CUPS and HPLIP on Spruce, and I discoved someting. On Spruce I have a directory called /usr/share/ppd/hplip/ and that directory is loaded with HP ppd files. On Spruce the Model/Driver menu looks like this:


On Aspen, I have that directory, but there were no ppd files in it. This in spite of the fact that I uninstalled/reinstalled hplip/cups several times.

Anyway, I rsynced, the /usr/share/ppd/hplip/ directories. So now Aspen has all those HP ppd files as well. Then I restarted Aspen, went to localhost:631, and under Model/Drive I have:


So the HP (HPLIP) is *still* not showing up.

Grrrr. Driving me crazy.

comprookie2000 04-15-2006 07:47 PM

You may need to restart cups for them to show up.

walterbyrd 04-15-2006 07:57 PM

Nevermind, I got it. Whew, it was a pain.

After I rsynced all that stuff from the /usr/share/ppd/hplip/ directory, I noticed the /usr/share/cups/model/ directory on Spruce had a "hplip" directory that was missing on Aspen. So I rsynced the /usr/share/cups/model/ directory as well.

It worked. But, I still don't know why I having all that trouble in the first place.

JohnHatfield 11-09-2013 01:59 PM

CUPS and hplip
I have the same problem that you had
I have installed CUPS and hplip and have the following
/usr/share/hplip ..python software
//usr/share/cups/model/ .. which is empty
I gather that success comes when the above contains hplip
How do I get it there.
What does rsyncing mean?

All times are GMT -5. The time now is 02:40 AM.