LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   HPLIP keeps looping at plug-in installation (https://www.linuxquestions.org/questions/linux-software-2/hplip-keeps-looping-at-plug-in-installation-4175647505/)

Dan Suson 02-02-2019 02:24 PM

HPLIP keeps looping at plug-in installation
 
I have upgraded to slackware64-current and am trying to get my hp printers working again. Slackware-current uses hplip-3.18.12 and I am trying to get my HP LaserJet Professional P1102w connected over the network. I used hplip to set up the printer using the USB cable successfully, getting to the message that I needed to run hp-setup with the local IP number. When I did that, the printer is properly discovered. Clicking next on the GUI takes me to a screen that says I need to install a driver plug-in.

I have done this step numerous times both as root and as a regular user. First I told the program to download and install the plug-in from an HP authorized server. After agreeing to the license agreement, I am prompted to enter the root password. I do so and get a message that the Plug-in installation was successful. Clicking ok brings up a new screen that says

The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins.
Please run 'hp-plugin' as normal user to install plug-ins.
Visit http://hplipopensource.com for more information.

This takes me back to the device discovery page where it begins the process over again.

I have also found the hplip-3.18.12-plugin.run plugin and downloaded it into a local directory. Selecting it on the driver plug-in page results in the same loop: accepting the license, having to sign in as root, plug-in installation successful, error screen, and back to the discovery page.

Ultimately, the printer never shows up in the HP device manager and isn't available for printing. How can I break this cycle and get the printer installed?

agillator 02-03-2019 12:40 AM

You say you are using a USB cable. So are you setting it up as a local printer or as a network printer? If you are setting it up strictly as a local printer you shouldn't need an IP address for it. If setting it up as a network printer I'm guessing you are picking the wrong option at some point. They really are poorly worded and it is easy to do.

First, are you or did you try to use the HPLIP provided by your distro. Experience says those can cause problems. Check CUPS (localhost:631) and make sure your printer is not there in any form. If it is, then delete it. Then purge (not just remove) your distro's version of HPLIP. Download HP's version - download fresh even if you downloaded it before. Unpack it, change the run file to executable if necessary. Be sure you printer is not connected to your computer. I am assuming your printer can work over wireless. Set it up according to its instructions. Now, run the HPLIP run file. To be on the safe side tell it to load all the dependencies, required and optional. At the end, do NOT connect by USB but tell the setup it is a wireless network (not connected by USB in any way). Note there are two network options but one requires a USB connection. That is NOT the one to select. It should find it. If it doesn't, get the ip from your printer in its network setup page and tell the HP setup to find that IP. It should and you should have no more problem.

frankbell 02-03-2019 09:15 PM

If you want to set this up as a network printer, than using a USB cable is red herring.

I would recommend strongly giving the printer a static ip address--it makes life with a network printer a lot easier. You should be able to do this through the printer settings menu.

Then you can install it to your computer using the HPLIP GUI (hp-toolbox) as user if the GUI is installed or, as root, you can install it from the command line with this command:

Code:

hp-setup - i [printer IP address]
hp-setup will ask you a series and questions and conclude by asking whether you want to print a test page.

If using the GUI tool, when you get to the Device Discovery dialog, click "Advanced Settings" to specify the printer ip address.

zaskar_84 02-06-2019 10:06 AM

I've been having the same problem since some update last december, and today I found a workaround. If you run the hp tools with "-g" they print some extra debug info in the terminal... There you can see that some dependencies are not being properly loaded. I see messages like:

hp-setup[31158]: debug: Either /usr/lib/i386-linux-gnu/sane/libsane-hp2000S1.so file is not present or symbolic link is missing
hp-setup[31158]: debug: /usr/lib/i386-linux-gnu/sane/libsane-hp2000S1.so library status: 0

These files are in /usr/lib/sane and /use/lib64/sane in slackware (I think Ubuntu and similar distros use i386-linux-gnu and x86_64-linux-gnu instead of lib and lib64). So I created a few symllinks in order to make hp* find those libs and it started working... I first created the dirs:

/usr/lib/i386-linux-gnu
/usr/lib64/x86_64-linux-gnu

then, made the symlinks:

/usr/lib/i386-linux-gnu/sane -> /usr/lib/sane
/usr/lib/x86_64-linux-gnu -> /usr/lib64/x86_64-linux-gnu
/usr/lib64/x86_64-linux-gnu/sane -> /usr/lib64/sane

and that made hp stop asking for the plugin installation over and over again

siliconepony 06-11-2019 11:53 PM

HPLIP keeps looping at plug-in installation - FIXED
 
Only replying as the fix zaskar_84 supplied worked like a charm. I'm surprised the fix is the re-pointing directories to files that are already there!

For those of you who are trying to reinstall the plugin, download directly from the plugins link, do try zaskar_84's fix below.

It works!

Valent 10-11-2019 06:25 AM

Thanks @zaskar_84

Same issue on Fedora, after creating same symlinks hp-setup finally installed the printer with scanner and fax functions... finally!

Tomas_IV 01-08-2020 03:51 AM

I had similar problem as OP, only it occured after an update - the printing and scanning was already configured and worked well, but "plugin installation needed" pop-up had been appearing once or several times a day with the loop described (installation seemingly successful and then report it failed).
I have Color LaserJet Pro MFP M277dw and hplip ver. 3.18.12 with HP Device Manager ver. 15.0, on Debian (10.2) based 64bit SolydX Linux distro. I also noticed a keyring issue when running hp-plugin in interactive mode in terminal and on GUI also had a popup for root password with user root filled in, while using a sudo system - I thought these might be the reasons for plugin installation failing and the "plugin installation needed" popup reappearing. But no, after applying modified solution based on post #4, the pop-up does not occur anymore and if I run the hp-plugin manually, it now informs me the plugin is already installed and no action is needed.
The modification of #4 solution on my system was, that I had to make only these symbolic links (and no new directories were needed to create):

sudo ln -s /usr/lib/x86_64-linux-gnu /usr/lib64/
sudo ln -s /usr/lib/sane /usr/lib/i386-linux-gnu/

It depends on what dirs are missing and where you already have the missing library files in the logs.

Note: I suppose this workaround is not entirely clean, because I found that at least in my case the library libsane-hp2000S1 in /usr/lib/sane I linked to /usr/lib/i386-linux-gnu/ is actually the same 64-bit one as that in /usr/lib64/ and not i386, but it works (and the hp-plugin still did complain about missing i386 libraries in the log even when I already made the first link, so I suppose it was necessary for it to function properly).

gss-in-oz 11-09-2020 06:00 AM

In case this helps anyone else who finds this thread and is helped by it as I was-
I'm running Majaro KDE 5.20.2 (5.18.1 kernel), and found that the following worked for me to install my HP LaserJet CP1025nw:

1. Changing the keyserver as described in post #4.
2. Creating the following soft links:

Code:

sudo ln -s /usr/lib /usr/lib/i386-linux-gnu
sudo ln -s /usr/lib64 /usr/lib64/x86_64-linux-gnu
sudo ln -s /usr/lib64 /usr/lib/x86_64-linux-gnu

As noted at the beginning of post #4, running
Code:

hp-setup -g
and getting the error messages about which directories appear to be 'missing' and which corresponding directories the files can be found in is really useful to discover what links your particular distribution might need.


All times are GMT -5. The time now is 03:08 PM.