-   Linux - Software (
-   -   How to use USB devices (a webcam in this case) in Wine 1.3.16? (

Neyzan 04-09-2011 08:05 AM

How to use USB devices (a webcam in this case) in Wine 1.3.16?
I am trying to use a webcam with integrated mic in Wine 1.3.16, but Wine doesn't seem to recognise the device. I am using Fedora 14 with a 2.6.35 Linux Kernel and a 2.32 Gnome GUI. The device works normally otherwise in Fedora. Is there a way to connect the webcam (and generally USB devices) to Wine?
I suspect that it could be done through the Drives tab of Wine configuration, but I don't know how to determine the path of the device to try this out. Does anyone know if this works and how to do it, or any other way to solve this problem?

Neyzan 04-09-2011 03:57 PM

PROBLEM SOLVED: I ran "dmesg" in the terminal and saw in the backtrace that the webcam was referred to as usb1 (it was in a line referring to the input of the device), so I went to the Drives tab of the Wine Configuration menu and I added a drive specifying as its path /dev/usb1. Now the webcam is recognised in Wine and works perfectly...

Neyzan 04-10-2011 07:46 PM

It seems I cheered too soon: When I used Wine today it didn't recognise the webcam again. I checked out the link in .wine/dosdevices and it was reported broken because the device /dev/usb1 doesn't exist. The backtrace of "dmesg" still refers to the webcam as usb1 and it's working fine otherwise. I tried deleting the drive from Wine Configuration and creating it again, I ran "ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com2" (which I found in the Advanced Wine Installation in, "ln -s /dev/usb1 ~/.wine/dosdevices/com2" and "ln -s /dev/ttyUSB0 ~/.wine/dosdevices/q:" in the terminal, but the problem remains. I assume that something is blocking Wine's access to the USB device, but I have no idea what. Does anyone know how to find this out and/or how to fix it?

Neyzan 04-12-2011 05:38 PM

109 views until now and still no reply, this must be a hard one. If someone even knows were I could look for a solution please tell me...

Neyzan 04-15-2011 03:06 PM

Still no answer...
I tried following the procedure as stated in, but the patches in are for Wine 1.1.28, so they are not up to date with the current version of Wine (1.3.16). Does anyone know if current patches exist somewhere or, alternatively, how to update the patches for Wine 1.1.28 so that they will apply for Wine 1.3.16?

Neyzan 04-16-2011 12:48 PM

It seems that PulseAudio still doesn't work with Wine. There was the problem all along (I hope at least that I will not have any problems again). I switched to the ALSA Driver in the Audio tab of Wine Configuration and now the mic of the webcam is working fine. No need to determine it's path in the Drives tab. I don't know if Wine's update to 1.3.17 today has anything to do with it or not, but anyhow, problem solved.

kameltreiber 04-28-2011 06:25 AM

Hello Neyzan,

thanks for all the useful information you posted here, I'm currently trying to get my webcam to work in wine, too.
However, my dmesg does not tell me (Debian Squeeze user) anything about my (integrated) usb webcam being a specific device like /dev/usb1. I only have a /dev/video0 which seems to be a character device and anyway, I can't really access it in vlc under wine (in Linux it works fine). What program do you use and how do you select the video source?

Concerning PulseAudio, I maybe can help you. Have you tried the patch winepulse? I did and it works for me. It's available here. Make sure you get the right version of the patch, but the one for 1.3.17 is easy to find:-).

Thanks in advance,

Neyzan 05-05-2011 11:27 AM

I suppose that you have a laptop or netbook? I am not really familiar with those (I have an old desktop) but I don't think you need to bother with dmesg. That was some of my experimentation when I was trying to find a solution, but as you can see in my previous post I didn't need it in the end. I focus on the mic of my webcam because that is mainly what I use in Wine (I need it for Rosetta Stone).
I suggest that you check out the Wine Configuration. Also, maybe you need to install a graphics driver in Wine, what kind of graphics card do you have in your computer?
Thanks for the link to the winepulse patch. The site seems to be temporarily unavailable, but I will check it out again later.

P.S.: Wine is now 1.3.18

sotel 12-18-2011 10:12 PM

No USB-device support under wine
The USB-support under wine is still not complete or better said: isn't in the way to get ready. Generally USB is hardware, and wine didn't support any hardware. It is an other concept.
Thats all.

Read also: USB device support in Wine

no2498 12-22-2011 06:39 AM

on some lap tops you need to use the fn key + a f1 threw f12 keys to turn the cam on
im not sure of what f-1-12 key it is you need to use
after you get its light on rerun dmesg
you should see the cam now in the dmesg

All times are GMT -5. The time now is 02:42 AM.