-   Linux - Software (
-   -   how to upgrade to admin a/c (

samnjugu 04-17-2006 02:11 PM

how to upgrade to admin a/c
Am running fc4 and i would like to know how i can upgrade my user a/c to an admin a/c as with my a/c i can't install coppermine. i get
you dont have permission to access /cpg/144/install.php.
Any help will be appreciated.:confused:

acid_kewpie 04-17-2006 02:16 PM

you don't change your account, you just log in as root in the first place, or become root with the su command.

samnjugu 04-18-2006 03:37 AM

thank you i have never logged in as root i always use the su command but since in need to run the script in my browser that is why i asked as the browser need to run in an admin login, to log in as root do i use the username: root i know it's kind of stupid to ask but i have never known how i can log in as root.

pslave 04-18-2006 03:41 AM

You can add your default user to sudo list.

man sudo for more info

samnjugu 04-18-2006 05:31 PM

thanks but even root cant install since it runs from browser i still got the same error message, so i think my nobody settings need editing as that is what apache uses to browse. am watching another thread where i put up the user: nobody issue to see if i will get any help thanks though

acid_kewpie 04-19-2006 01:12 AM

what runs for a browser?? there's no way you should be able to install stuff via a web browser... that's where rootkits and other exploits come from. instead save the file, become root, and then install.

samnjugu 04-19-2006 07:19 AM

am trying to install coppermine photo gallery and they say on directions of how to install is that you place install directory in your web directory and you run the installer from your browser with the path "httP://your.domain/coppermine/install.php" where coppermine is whatever name you rename the folder containing install files.
here is a link to the documentation provided for installing since i may be phrasing my question wrongly:

but the error mesage i get no matter my login is: "you dont have permision to access /cpg144/install.php on this server" i have tried puting the whole folder on chmod 777 just to see if it will work but nothing works the same error message keeps coming back.

acid_kewpie 04-19-2006 08:24 AM

that sounds like your apache server is not configured correctly...

samnjugu 04-20-2006 07:51 AM

i finnaly solved it and thanks acid for your heads up, my problem was the chcon command since that is what apache uses to know what to open or not suffice it to say even by setting the appropriate chmod command without setting the required chcon apache wont run scripts.

acid_kewpie 04-20-2006 08:34 AM

chcon? ACK!! SELinux strikes again!!

All times are GMT -5. The time now is 07:33 PM.