LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-20-2016, 04:16 AM   #1
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130
Blog Entries: 2

Rep: Reputation: 8
how to un skip packages with broken dependencies


Hello world,

When I run the command ' dnf update ' I am getting same message again and again,

I am unable to run updates using DNF or even YUM.

dnf -y update
Last metadata expiration check performed
Dependencies resolved.
================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Skipping packages with broken dependencies:
galera x86_64 25.3.12-1.rhel7.el7.centos mariadb 7.7 M

Transaction Summary
================================================== ==============================
Skip 1 Package

Nothing to do.
Complete!


How can I update this package, and not skip it anymore. I am running FC 23 with MariaDB 10.1

Any help is appreciated.
__________________
Linux Newbie - Information is Power!
Download Linux @ http://www.fedora.redhat.com/
May the Linux force be with you!
Fedora 23 - MariaDB 10.1

Last edited by cyberdome; 02-20-2016 at 04:17 AM.
 
Old 02-20-2016, 04:31 AM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Hi...

Did you add a repository or do anything before this happened? Does this command show any further detail...

Code:
sudo dnf update --best --allowerasing
Also, what is the result of this command...

Code:
sudo dnf repolist
Thanks!

Last edited by ardvark71; 02-20-2016 at 04:57 AM. Reason: Correction.
 
Old 02-20-2016, 05:05 AM   #3
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130

Original Poster
Blog Entries: 2

Rep: Reputation: 8
Yes, I updated the MariaDB repo from 10.0 to 10.1 to update MariaDB server and client. Also, I upgraded just recently from Fedora 22 to Fedora 23. I had to run command with --skip-broken. That is only way I could get around to update to FC23.. But now I keep getting this galera broken message. Hope I am making any sense.



dnf -y update
Last metadata expiration check performed
Dependencies resolved.
================================================================================
Package Arch Version Repository Size
================================================================================
Skipping packages with broken dependencies:
galera x86_64 25.3.12-1.rhel7.el7.centos mariadb 7.7 M

Transaction Summary
================================================================================
Skip 1 Package

Nothing to do.
Complete!

=============================================================================
dnf update --best --allowerasing
Last metadata expiration check performed
Error: nothing provides libboost_program_options.so.1.53.0()(64bit) needed by galera-25.3.12-1.rhel7.el7.centos.x86_64

==============================================
dnf repolist
Last metadata expiration check performed
repo id repo name status
*fedora Fedora 23 - x86_64 46,074
google-chrome google-chrome - \x86_64 3
mariadb MariaDB 13
*updates Fedora 23 - x86_64 - Updates 16,098

Last edited by cyberdome; 02-20-2016 at 02:13 PM.
 
Old 02-20-2016, 02:12 PM   #4
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Hi...

I believe this is your issue...

Quote:
Error: nothing provides libboost_program_options.so.1.53.0()(64bit) needed by galera-25.3.12-1.rhel7.el7.centos.x86_64
If I understand correctly, "galera x86_64 25.3.12-1.rhel7.el7.centos mariadb 7.7 M" doesn't work because the package "libboost_program_options.so.1.53.0()(64bit)" is missing.

To install the missing dependency, download the "boost-program-options" package here and try installing it. However, I'm not entirely sure if it will work.

Hopefully, you will not need any further dependencies.

Regards...

Last edited by ardvark71; 02-20-2016 at 02:17 PM. Reason: Deleted information/Changed wording.
 
Old 02-20-2016, 02:34 PM   #5
cyberdome
Member
 
Registered: Mar 2014
Distribution: Fedora 23 - MariaDB 10.1 -
Posts: 130

Original Poster
Blog Entries: 2

Rep: Reputation: 8
Thank you for the website. I really appreciate it. I just don't understand why do I keep getting message when I run the dnf update command. Looks like I already have the latest boost package. See below message.


# rpm -ivh --nodeps ftp://ftp.muug.mb.ca/mirror/centos/7...el7.x86_64.rpm


Retrieving ftp://ftp.muug.mb.ca/mirror/centos/7...el7.x86_64.rpm
warning: /var/tmp/rpm-tmp.IETuvj: Header V3 RSA/SHA256 Signature, key ID f4a80eb5: NOKEY
Preparing... ################################# [100%]
package boost-program-options-1.58.0-11.fc23.x86_64 (which is newer than boost-program-options-1.53.0-25.el7.x86_64) is already installed
 
Old 02-20-2016, 04:07 PM   #6
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by cyberdome View Post
# rpm -ivh --nodeps ftp://ftp.muug.mb.ca/mirror/centos/7...el7.x86_64.rpm


Retrieving ftp://ftp.muug.mb.ca/mirror/centos/7...el7.x86_64.rpm
warning: /var/tmp/rpm-tmp.IETuvj: Header V3 RSA/SHA256 Signature, key ID f4a80eb5: NOKEY
Preparing... ################################# [100%]
package boost-program-options-1.58.0-11.fc23.x86_64 (which is newer than boost-program-options-1.53.0-25.el7.x86_64) is already installed
Hi...

The problem is that it appears your version of galera is requiring the older, CentOS based version of "boost-program-options." You can see if the older version will install beside the newer, Fedora based version and if not, downgrade to the older version. However, you run the risk of possibly breaking something else in the process. Be careful here.

Regards...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
should you ever skip broken packages sigint-ninja Linux - Newbie 3 01-02-2016 11:29 AM
[SOLVED] aptitude: install new packages when an existing package has broken dependencies otoomet Linux - Software 6 02-20-2015 12:06 PM
[SOLVED] how to make apt-get ignore broken packages and missing dependencies gujedan Linux - Networking 3 03-20-2011 01:54 PM
Broken Packages and Unresolved Dependencies dauphinfay Linux - Software 2 08-24-2008 10:15 AM
Continuing to upgrade and install new packages with broken dependencies in the system nautilus Debian 3 06-13-2007 06:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration