LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-05-2010, 05:59 AM   #1
haribabu1836
LQ Newbie
 
Registered: Apr 2010
Posts: 16

Rep: Reputation: 0
how to stopping irqbalance service in kernel


I want to disable the irqbalance service.how i can do this?
i given the below command from prompt,but it is showing failed.
i have fedora core10.
]#service irqbalance stop
]#stoping irqbalance: [FAILED]


it is very thanksfull if any one give answer.
 
Old 04-05-2010, 08:24 AM   #2
slist
LQ Newbie
 
Registered: Jan 2008
Location: France, Lyon
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
killall -9 irqbalance
 
Old 04-05-2010, 08:51 AM   #3
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
You can also try the 'acpi_irq_nobalance' kernel parameter as a boot option.

This seems to be something distro-specific, so I can't be sure.
 
Old 06-16-2010, 02:39 PM   #4
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,254

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Question

Quote:
Originally Posted by H_TeXMeX_H View Post
You can also try the 'acpi_irq_nobalance' kernel parameter as a boot option.
How exactly can this be done in Ubuntu?
 
Old 06-16-2010, 03:07 PM   #5
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
You'd have to add it to /boot/grub/menu.lst somewhere in there, can you post it.
 
Old 06-17-2010, 04:24 AM   #6
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,254

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Exclamation

Grub2 does not contain anything like /boot/grub/menu.lst

There is: sudo gedit /etc/default/grub

My file contains:
Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap"
GRUB_CMDLINE_LINUX=" splash vga=789"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
GRUB_GFXMODE=1280x1024

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Where exactly would 'acpi_irq_nobalance' go?

Last edited by linustalman; 06-17-2010 at 04:34 AM.
 
Old 06-17-2010, 05:23 AM   #7
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
I see, this is grub2, didn't know, it would probably have to be:

Code:
GRUB_CMDLINE_LINUX=" splash vga=789 acpi_irq_nobalance"
 
Old 06-18-2010, 03:34 AM   #8
linustalman
Senior Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Debian 10 (Buster) x64
Posts: 4,254

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Lightbulb

Thank you H_TeXMeX_H. I will make a note of it.

This seems to have done the trick:
Code:
sudo aptitude purge irqbalance
 
Old 01-07-2011, 03:49 AM   #9
dcstar
LQ Newbie
 
Registered: Feb 2005
Distribution: Ubuntu 10.04
Posts: 4

Rep: Reputation: 0
Editing the /etc/default/irqbalance file and disabling it there would also probably be effective.
 
  


Reply

Tags
kernel, linux


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stopping irqbalance: Failed 9nine9 Fedora 3 11-25-2007 01:01 PM
NAMED Service Not Stopping dsschanze Linux - Networking 3 08-06-2007 06:03 AM
Problem stopping linux service ruffieux Linux - General 4 02-09-2006 03:36 PM
Stopping exim service ginnotech Debian 2 11-03-2004 10:41 AM
Stopping a startup service MrJoshua Linux - General 1 05-15-2002 03:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration