LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   how to stopping irqbalance service in kernel (https://www.linuxquestions.org/questions/linux-software-2/how-to-stopping-irqbalance-service-in-kernel-800085/)

haribabu1836 04-05-2010 05:59 AM

how to stopping irqbalance service in kernel
 
I want to disable the irqbalance service.how i can do this?
i given the below command from prompt,but it is showing failed.
i have fedora core10.
]#service irqbalance stop
]#stoping irqbalance: [FAILED]


it is very thanksfull if any one give answer.

slist 04-05-2010 08:24 AM

killall -9 irqbalance

H_TeXMeX_H 04-05-2010 08:51 AM

You can also try the 'acpi_irq_nobalance' kernel parameter as a boot option.

This seems to be something distro-specific, so I can't be sure.

linustalman 06-16-2010 02:39 PM

Quote:

Originally Posted by H_TeXMeX_H (Post 3924775)
You can also try the 'acpi_irq_nobalance' kernel parameter as a boot option.

How exactly can this be done in Ubuntu?

H_TeXMeX_H 06-16-2010 03:07 PM

You'd have to add it to /boot/grub/menu.lst somewhere in there, can you post it.

linustalman 06-17-2010 04:24 AM

Grub2 does not contain anything like /boot/grub/menu.lst

There is: sudo gedit /etc/default/grub

My file contains:
Code:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap"
GRUB_CMDLINE_LINUX=" splash vga=789"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
GRUB_GFXMODE=1280x1024

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Where exactly would 'acpi_irq_nobalance' go?

H_TeXMeX_H 06-17-2010 05:23 AM

I see, this is grub2, didn't know, it would probably have to be:

Code:

GRUB_CMDLINE_LINUX=" splash vga=789 acpi_irq_nobalance"

linustalman 06-18-2010 03:34 AM

Thank you H_TeXMeX_H. I will make a note of it.

This seems to have done the trick:
Code:

sudo aptitude purge irqbalance
:hattip:

dcstar 01-07-2011 03:49 AM

Editing the /etc/default/irqbalance file and disabling it there would also probably be effective.


All times are GMT -5. The time now is 09:24 AM.