-   Linux - Software (
-   -   How to stop mplayer from resuming play when any key is pressed (slave mode)? (

lumix 10-19-2008 04:28 PM

How to stop mplayer from resuming play when any key is pressed (slave mode)?
This is bad behavior. there's a 'p' button in normal mode, and a "pause" command in slave mode so that you can control pause and unpause nicely. pressing the letter, oh, say...'x' shouldn't have anything to do with pausing and the like. But it does.

Anyone know a way around this?

haveanicelife 05-30-2012 10:32 PM

My apologies for bumping such an old thread, but this is the only search result relating to this query I can find.

I've just started using mplayer and have everything tuned just as I like it, except for this issue. I would like to be able jump in and out of fullscreen mode without my video resuming. As lumix wants, I only wish for mplayer to pause/unpause when SPACE or p is pressed.

Any ideas?

kevin-d 07-19-2012 11:34 AM

It's possible, but there will be some problems.

You need to rebind keys in your ~/.mplayer/input.conf (see example in /etc/mplayer/input.conf or something like that, depending on distribution). If you'd like to disable all the default keys, use command-line option -input nodefault-bindings.

As for what you need to change, look at But remember that "pausing_keep " would still play through some frames while the command is executed, and then pause again. Also, this frequent pausing/unpausing will break audio/video sync temporarily (it will be gradually restored, see command-line -autosync option). There's also "pausing_keep_force " which doesn't pause/unpause but is experimental and not guaranteed to work.

As for me, I was particularily bothered by the fact that video starts playing when I just want to see time elapsed (key P), so I used the following line, which toggles pause and displays time on Space, and was done with it.
SPACE pausing_toggle osd_show_progression

All times are GMT -5. The time now is 10:22 AM.