LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-03-2005, 11:49 PM   #1
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Rep: Reputation: 30
How to start mysqld without the skip networking option?


Dear friends,

I am trying to configure knowledgetree with its fileindexer.

I need to start mysqld without the "skip networking" option. I looked into the config file /etc/my.cnf doesn't have the skip networking option in there. heres the my.cnf:

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock


[mysql.server]
user=mysql
basedir=/var/lib

[safe_mysqld]
err-log=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid


Seems short and simple. No skip-networking option to be uncommented.
Someone teach me :

start mysqld
with the "--skip-networking" option.

but I don't want it to start with skip-networking, how do I do that? thanks a lot for taking time reading my mail!
 
Old 06-05-2005, 11:33 AM   #2
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 52
What is your problem? If you want the skip-networking option add it else leave your configuration file like it is.
 
Old 06-07-2005, 03:01 AM   #3
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Hi mrcheeks,

Thanks for your help,

My problem is that, seems like my mysql cannot listen with TCP. I am trying to configure fileindexer for knowledgeTree, and getting error which might be caused by my mysql's inability to listen through TCP. Someone in forum told me to try

mysql -u root -h 127.0.0.1 -P3306 , if it works then its listening through TCP. but I got error as below:

ERROR 1130: Host 'localhost.localdomain' is not allowed to connect to this MySQL server

Someone also told me to mysql to listen through TCP, I have to comment the "skip networking" option so that it doesn't not skip networking.
I tried to do that but my my.cnf config file doesn't have such option, in fact my my.cnf is very simple and short as below:

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

[mysql.server]
user=mysql
basedir=/var/lib

[safe_mysqld]
err-log=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

My spec:
fc2
mysql-3.23.58-9
(Everything I am using comes with distribution)

So, what I need is to enable mysql to listen through TCP...but can't figure out how to...,,,
thanks a lot for your help sir.
 
Old 06-07-2005, 03:26 AM   #4
nvm
LQ Newbie
 
Registered: Jun 2005
Location: Glasgow, Scotland
Distribution: Debian
Posts: 12

Rep: Reputation: 0
Paste here exactly what happens when you type:

mysql -u root -p
 
Old 06-07-2005, 07:07 AM   #5
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 52
do you have a firewall?
 
Old 06-07-2005, 07:36 PM   #6
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Dear friends,

Thanks a lot for helping! I have got it sorted out.
the error msg I got: ERROR 1130: Host 'localhost.localdomain' is not allowed to connect to this MySQL server

What I did I just give permission to host = localhost.localdomain in mysql. After that it works....I am so stupid....

Now my indexer and archiver for knowledgetree works.

Thanks a lot guys for helping,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mysqld: unrecognized option `--skip-external-locking' MaulingMonkey Linux - Software 0 01-11-2005 02:01 PM
How to start mysqld with the --old-passwords option ? alphaque Linux - Software 2 12-01-2004 07:54 PM
MySQL can't connect(skip-networking commented) mrcheeks Debian 0 11-21-2004 11:30 AM
how can i start mysqld? yenonn Slackware 6 11-28-2003 09:32 PM
How to boot Mandrake Linux faster (skip boot option) lava Linux - General 7 02-28-2003 02:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration