Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 11-18-2004, 12:51 AM   #1
LQ Newbie
Registered: Nov 2004
Posts: 9

Rep: Reputation: 0
How to start mysqld with the --old-passwords option ?


i installed the Fedora Core 3, PHP 4.3.9 and MySQL4.1.17 in a server, everytime when i try to connect to MYSQL server from a PHP script, it reported an error "Client does not support authentication protocol requested by server; consider upgrading MySQL client". From the Mysql web site, i came to know i have to start mysqld with the --old-passwords option in my Fodora in order for the error to go away

Now , my question is where do i add that option so every time when i start up my fedora server that "--old-passwords" option will be enabled by default ? I checked the /etc/inittab and /etc/rc.local files, i couldn't see any "mysqld" entry there where i can append the option switch..Any help ?


Last edited by alphaque; 11-18-2004 at 12:53 AM.
Old 12-01-2004, 03:10 AM   #2
LQ Newbie
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0

This got me through.

In the /etc/my.cnf file

and the following commands in mysql:

mysql>use mysql;
mysql> UPDATE user SET Password = OLD_PASSWORD('mypass')
-> WHERE Host = 'some_host' AND User = 'some_user';
with the appropriate values substituted.

Best of luck!
Old 12-01-2004, 07:54 PM   #3
LQ Newbie
Registered: Nov 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Smile it works!

Hi Rini,
thanks., it works !


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start mysqld without the skip networking option? Niceman2005 Linux - Software 5 06-07-2005 07:36 PM
mysqld: unrecognized option `--skip-external-locking' MaulingMonkey Linux - Software 0 01-11-2005 02:01 PM
Slack 10, fresh install, mysqld start problem. jml75 Slackware 6 08-17-2004 09:26 PM
how can i start mysqld? yenonn Slackware 6 11-28-2003 09:32 PM
mysqld start linuxRules Linux - General 1 07-21-2002 03:06 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:31 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration