LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-29-2006, 04:28 AM   #1
darthfoolish
Member
 
Registered: May 2006
Posts: 52

Rep: Reputation: 15
How to silently automount DVD in FC4?


I want to be able to insert a DVD and have it silently mounted automatically, but not have anything else play

Just have its' contents availiable, like the Windows behaviour with autorun disabled

If it's not possible to have it done silently, then a way to get rid of dialog boxes through a script would be fine.

At the moment when I insert a DVD, I can have it automatically mount, but I have two dialog boxes pop up.

One is an error (which I believe to be bogus, because the mounting still works) of "/media/cdrom is a folder, but a file was expected"

The other is "mount: block device /mnt/hdc is write protected, mounting read-only"

When I click on the OK button in the error box, the other box also disappears.
 
Old 07-29-2006, 06:51 AM   #2
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Rep: Reputation: 30
hi,
pls list me the line for the cdrom in fstab file
regards,
tom.
 
Old 07-29-2006, 09:47 AM   #3
darthfoolish
Member
 
Registered: May 2006
Posts: 52

Original Poster
Rep: Reputation: 15
here is the line in question

/dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0
 
Old 07-31-2006, 02:11 AM   #4
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Rep: Reputation: 30
hi,
here are some tips!
1)check for the permission rights of /media/cdrom folder
2)your second error is "mount: block device /mnt/hdc is write protected, mounting read-only"

but you mounting point is /media/cdrom , so check for the entries in /etc/mtab file forcdrom

3)Try to control the automount feature using kde control center it use kde or gnome's
4)if you are trying to mount it as an user , add the term user to 4th entry in the fstab file
regards,
tom.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Automount dvd ROM when dvd is inserted baddah Linux - Newbie 9 06-20-2006 01:05 PM
Automount DVD Denham2010 Linux - Hardware 1 05-18-2006 05:31 PM
Automount DVD Drive w/ Permissions jerm1701 Linux - General 4 03-02-2006 05:00 PM
Disable Automount FC4 fuzzyheadedfreak Linux - Newbie 1 12-18-2005 01:39 AM
Automount DVD and playback when DVD installed khurtwilliams Linux - Software 2 05-28-2004 01:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration