LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-02-2005, 05:37 PM   #1
donJulio
LQ Newbie
 
Registered: Sep 2005
Location: California
Distribution: Slackware
Posts: 23

Rep: Reputation: 15
How to set wallpaper in fluxbox at startup?


I've edited the file:
$HOME/.fluxbox/startup
and added this line:
fbsetbg -f /home/donjulio/backgrounds/wall1_1024.jpg
and when I start the X server, the background appears for just a moment then the default background for my chosen style pops up. How do I fix this?

BTW, if I run the same command:
fbsetbg -f backgrounds/wall1_1024.jpg
the wallpaper does change, though it's not something I want to do every time I log in. Thanks!
 
Old 10-02-2005, 06:45 PM   #2
Sargek
Member
 
Registered: Jan 2003
Location: San Antonio, Texas
Distribution: Debian testing
Posts: 416

Rep: Reputation: 36
Re: How to set wallpaper in fluxbox at startup?

Quote:
Originally posted by donJulio
I've edited the file:
$HOME/.fluxbox/startup
and added this line:
fbsetbg -f /home/donjulio/backgrounds/wall1_1024.jpg
and when I start the X server, the background appears for just a moment then the default background for my chosen style pops up. How do I fix this?

BTW, if I run the same command:
fbsetbg -f backgrounds/wall1_1024.jpg
the wallpaper does change, though it's not something I want to do every time I log in. Thanks!
\

The particular style you chose probably has a rootCommand to change the wallpaper in it. Here is what I do on Openbox, but it will work for Fluxbox as well:

In .xinitrc, I have this line:
Code:
eval `cat ~/.fehbg`
which executes the last command feh ran, which is stored in ~/.fehbg. I used to set my wallpaper in Fluxbox by using a menu option like this:

Code:
[submenu] (Wallpaper)
      [wallpapers] (/home/paul/wallpaper) {feh --bg-scale}
[end]
This tells Fluxbox to scan the directory /home/paul/wallpaper and pass the chosen file to feh --bg-scale, which sets my wallpaper. Not sure how fbsetbg works because I use feh, but if you look on Fluxbox's site, they may be able to provide some more insight. Also, I am not sure how you start Fluxbox - I boot to the command line and run "startx" to get into X. If you use GDM, or XDM, not sure how to set this up - maybe in .Xsession? Hope this helps.
 
Old 12-25-2005, 01:45 PM   #3
-=|Man0waR|=-
LQ Newbie
 
Registered: Feb 2005
Distribution: Ubuntu 5.10
Posts: 5

Rep: Reputation: 0
I've just switched to fluxbox and expirienced the same problem.

The problem is that every style has it's own background setting, so,
when fb loads the style it also loads the styles background, on top of whatever you loaded first with fbsetbg.

So I search for a setting and yep... it's in
/usr/share/fluxbox/styles/the_name_of_the_style

search in the file for:

rootCommand: bsetroot -solid some_color

erase this line and it should work.
 
Old 12-27-2005, 12:40 PM   #4
donJulio
LQ Newbie
 
Registered: Sep 2005
Location: California
Distribution: Slackware
Posts: 23

Original Poster
Rep: Reputation: 15
That would work with a particular style. I don't remember how I got around it, but basicly I edited something (I wish I could remember what) so that it would load the last wallpaper used. Now, I can change styles and the wallpaper doesn't change. I just wish I could remember what I did to make it work that way.
 
Old 12-27-2005, 07:08 PM   #5
Oxagast
Member
 
Registered: Aug 2003
Location: Mocksville, NC, USA
Distribution: Gentoo, Slackware.
Posts: 410

Rep: Reputation: 30
There should be a line in ~/.fluxbox/init that says "session.screen0.rootCommand:", change it to "session.screen0.rootCommand: fbsetbg -l" (to set the last wallpaper that fbsetbg set), or whatever. Thats a cleaner solution then hacking the theme file, as you do not have to edit files that are not normally writable by your user, and you can change the theme around and have the wallpaper settings stick, and I believe the init file takes priority over the theme files.
 
Old 12-28-2005, 03:02 PM   #6
donJulio
LQ Newbie
 
Registered: Sep 2005
Location: California
Distribution: Slackware
Posts: 23

Original Poster
Rep: Reputation: 15
That's what it was. Thanks!
 
Old 08-16-2009, 03:25 PM   #7
allele
Member
 
Registered: May 2009
Posts: 42

Rep: Reputation: 16
Quote:
Originally Posted by Oxagast View Post
There should be a line in ~/.fluxbox/init that says "session.screen0.rootCommand:", change it to "session.screen0.rootCommand: fbsetbg -l" (to set the last wallpaper that fbsetbg set), or whatever. Thats a cleaner solution then hacking the theme file, as you do not have to edit files that are not normally writable by your user, and you can change the theme around and have the wallpaper settings stick, and I believe the init file takes priority over the theme files.
I am having the same problem (on Fedora 11), and this doesn't work for me.
 
Old 08-16-2009, 03:38 PM   #8
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/Many
Posts: 5,573

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
You guys should check out grml's fluxbox

if your s is similar
look in /etc/X11/fluxbox

should be a file named "overlay"
here's wahat overlay says

Quote:
! The following line will prevent styles from setting the background.
! background: none
so, remove the ! from that, and in at least debian/grml, when you change a style
it won't change background

also, in debian/grml there is a file in /home/grml/.fluxbox named "lastwallpaper"
it says

Quote:
$full $full|/usr/share/wallpapers//grml.jpg||:0.0
and, here's my (work-n-progress) fluxbox menu
Note that I like to run as root!
Code:
[begin] (Fluxbox) {} <>
    [exec] (XTerm) {grml-exec-wrapper xterm} </usr/share/pixmaps/xterm-color_32x32.xpm>
    [exec] (Root Eterm) {sudo /usr/bin/Eterm} <>
    [exec] (Root Xterm) {sudo x-terminal-emulator} <>
    [exec] (Root Gedit) {sudo grml-exec-wrapper gedit} <>
    [exec] (Root-Rox) {sudo grml-exec-wrapper rox-filer}
    [exec] (GIMP) {/usr/bin/gimp} </usr/share/pixmaps/gimp.xpm>
    [exec] (Opera) {/usr/bin/opera} </usr/share/pixmaps/opera.xpm>
    [exec] (Links 2) {/usr/bin/links2 -g /usr/share/doc/grml-docs/startpage.html} </usr/share/pixmaps/links2.xpm>
    [exec] (Scrot 05)  {scrot -cd 5} <>
    [submenu] (handy stuff) {} <>
        [exec] (gftp) {grml-exec-wrapper gftp} <>
        [exec] (gedit) {grml-exec-wrapper gedit} <>
        
        [exec] (gkrellm) {grml-exec-wrapper gkrellm} <>
        [exec] (configure fluxbox [fluxconf]) {grml-exec-wrapper fluxconf} <>
    [end]
    [submenu] (grml) {} <>
        [exec] (lock X) {grml-exec-wrapper -p grml-lock x-terminal-emulator -T "grml-lock" -e /usr/bin/grml-lock} <>
        [exec] (configure mailclient mutt) {grml-exec-wrapper -p grml-mutt x-terminal-emulator -T "grml-mutt" -e /usr/bin/grml-mutt} <>
        [exec] (configure newsreader slrn) {grml-exec-wrapper -p grml-slrn x-terminal-emulator -T "grml-slrn" -e /usr/bin/grml-slrn} <>
        [exec] (configure network) {sudo x-terminal-emulator -T "grml-network" -e /usr/sbin/grml-network} <>
        [exec] (configure and run terminalserver) {grml-exec-wrapper -p grml-terminalserver sudo x-terminal-emulator -T "grml-terminalserver" -e /usr/sbin/grml-terminalserver} <>
    [end]
    [submenu] (Debian) {} <>
        [include] (/etc/X11/fluxbox/menudefs.hook) {} <>
    [end]
    [submenu] (Wallpapers)
        [wallpapers] (~/.wallpapers/) {fbsetbg}
        [wallpapers] (/usr/share/wallpapers/) {fbsetbg}
    [end]
    [config] (Configure) {} <>
    [submenu] (Styles) {Choose a style...} <>
        [stylesdir] (/usr/share/fluxbox/styles) {} <>
        [stylesdir] (~/.fluxbox/styles) {} <>
    [end]
    [workspaces] (Workspace List) {} <>
    [submenu] (Tools) {} <>
        [exec] (Windowname) {xprop|grep WM_CLASS|cut -d \" -f 2|xmessage -file - -center} <>
        [exec] (Run) {fbrun} <>
    [end]
    [reconfig] (Reload config) {} <>
    [restart] (Restart) {} <>
    [exit] (Exit) {} <>
[end]
the overlay file is also in /home/grml/.fluxbox

I just started downloading ANY distro that features fluxbox and try to rip off whatever I wanted
I'm trying to add Hag Linux's "devices" and volume button in toolbar

good ones

Hag Linux 0.1-20

GRML medium or full(full has awesome/ratpoison/fvwm/alots more

PupFlux 4.2+ a puppy with a nice fluxbox

Tinycore also has a nice fluxbox and hackedbox too

bottom here is grml
http://multidistro.com/fluxboxp/fluxboxp.html
 
Old 08-20-2009, 06:19 AM   #9
allele
Member
 
Registered: May 2009
Posts: 42

Rep: Reputation: 16
linus72: I am going to try that way as soon as I get a chance, but in the meantime, I discovered something: if I restart directly from fluxbox using sudo shutdown -r now — and after having done that, even if I exit fluxbox and then shutdown from gdm — my background (and transparency/pseudo-transparency in the menus!) works.

However I am confused because I have shutdown from fluxbox before and it didn't help, and I changed .fluxbox/startup and .fluxbox/init back to how they previously were. So I am wondering if it will just go away again, and a bit thrown by an OS which appears to change the way it behaves for no apparent reason.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox wallpaper setting fictos Debian 2 08-02-2005 10:21 PM
Fluxbox: How to Change Wallpaper? mrgrieves Linux - Software 2 08-27-2004 03:40 AM
fluxbox wallpaper johntramp Linux - Software 2 07-02-2004 10:57 PM
Can't set a wallpaper in Fluxbox 0.98 AMMullan Linux - Software 5 02-24-2004 09:01 PM
fluxbox wallpaper C8H10N4O2 Linux - Software 2 09-14-2003 03:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration