LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-09-2008, 01:00 PM   #1
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 473

Rep: Reputation: 30
How to run VNC server in 'always shared' mode?


It appears that when VNC server runs, it always run with 'alwaysshared' option off. This causes an existing client to be knocked out if someone else establishes a new connection.
How to enable this option (-alwaysshared)?
And, if VNC server is already running, is it possible to dynamically update it with this option.
Finally, how to manually stop and restart VNC server? 'vncserver -stop' doesn't seem to work. I am just trying to restart it without having to restart the machine.
Thanks.
 
Old 03-09-2008, 01:19 PM   #2
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Not knowing your way you setup or distro in question other than info in sig but in Fedora 8 you would edit /etc/sysconfig/vncserver file and the section for your addtional desktops then add the alwaysshared there. If you have it in say /etc/X11/xorg.conf then add a line like this.
option alwaysshared

Found this info from a quick google search from the following links. Many more links with great info if you setup is not like the two options listed here.
http://xf4vnc.sourceforge.net/doc.html
http://64.233.167.104/linux?q=cache:...lnk&cd=3&gl=us

Brian
 
Old 03-09-2008, 01:37 PM   #3
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 473

Original Poster
Rep: Reputation: 30
Brian,
Thanks for the links. This is a remote Redhat Enterprise machine. I just edited /etc/sysconfig/vncservers (note the plural) and added those two options in a single line (option alwaysshared dontdisconnect). Let's see if it works.
The machine also has an /etc/X11/xorg.conf, but I didn't edit.

Last edited by concoran; 03-09-2008 at 01:40 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fatal Server Error: Cannot run in framebuffer mode. gauntalus Linux - Software 4 01-06-2009 04:52 PM
Can not get vnc server to run on ubuntu cuschu Ubuntu 1 01-07-2007 02:04 PM
Should server run text mode? kola Linux - Networking 2 11-28-2004 05:15 PM
VNC login not shared question firefly2442 General 1 08-14-2004 07:06 AM
run vnc-server as other user in rc.local jvdbossc Linux - Newbie 2 05-26-2004 02:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration