-   Linux - Software (
-   -   How to reinstall GRUB or LILO? (

dhsieh 10-05-2003 06:53 PM

How to reinstall GRUB or LILO?
I have a dual boot system with Win2k & Redhat 9. Unfortunately, after installing the Redhat 9, I was unable to boot into Redhat. I tried both GRUB & LILO with no luck. In several tries, I installed the loader (GRUB & LILO) either in the MBR or the first sector of the Linux partiton. Although I was able to boot off the emerginecy disk I craeted during the installation. As a result, I believe that the Linux was installed successfully. It was jsut the loader didn't work. It has become quite annoying to reinstall the entire Linux from scrath in order to fix the loader. Is there a easier way to install the loader without having the reinstall the Linux?

- Dhsieh

damien 10-05-2003 07:03 PM

Did you run /sbin/lilo to set lilo up again from your new lilo.conf?

Check this out:


dhsieh 10-05-2003 07:47 PM

Yes, I did boot up using the mergency Linux disc and run /sbin/lilo.

[QUOTE]Originally posted by damien
[B]Did you run /sbin/lilo to set lilo up again from your new lilo.conf?

damien 10-05-2003 08:07 PM

Hmmm. Can you post your /etc/lilo.conf and the output from /sbin/lilo ?

Raspis21 10-05-2003 08:34 PM

If I might ask, what does it do when you try to boot to RH 9? Does it give any errors or anything? I think it might help. Also, when it boots, do you even get to the Grub or Lilo screen? Let us know a bit more, and maybe we can getcha going. If you never see the Grub of Lilo (and for some strange reason I prefer grub, could be the password ability, I am paranoid) then I think you might have a partition that isn't active. Perhaps we can figure it out.


dhsieh 10-05-2003 09:25 PM

I apologize for the lack of details in my original posting. What I did were:

(1) Before installing the Redhat 9, I have Win2k and I use System Commander 7 (SC) as its boot manager.

(2) Aftering installing Redhat 9 with GRUB on MBR (which works with my another PC), the SC added the Redhat 9 into the menu but was unable to boot it. I received just a line of "GRUB" and it halted.

(3) Then, I tried installing LILO with MBR. This time, LILO overwite the MBR and messed up the SC boot menu. I have restore the MBR from a back.

(4) Then, I tried installing LILO with its own partition, This time, SC was not able to detect and thus not adding Linix partiton into its boot menu.

- Dhsieh

dhsieh 10-05-2003 09:50 PM

I just disabled SC and installed PowerQuest PartitonMagic 8 in my Win2k. Just as SC, it can't add Linux (ext3) partition into its boot menu. For some reason, both boot manager softwares cann't seem to recongnize the Linux partition on the PC.

- Dhsieh

dhsieh 10-06-2003 01:52 PM

I installed another boot manager "SOL2000" and it recognizes the Linux parition. Now I can boot into Linux without a problem. Thanks for your helpful tip in resolving this problem.

- Dhsieh

All times are GMT -5. The time now is 01:25 AM.