-   Linux - Software (
-   -   How to mount my USB mobile disk (

malek_baklouti 04-15-2004 02:00 PM

How to mount my USB mobile disk
I m a newbie in Linux... I've recently installed it in my computer...
but Ican't use my usb mobile disk, it seems that it must be mounted before I can use it...
I would be gratefull if you can help me to mount it... should there be a driver that I must install before?

thank you very much

bryanl 04-15-2004 04:19 PM

you shouldn't need a driver if your linux is fairly up to date.

you will need to be root for these kinds of things.

first make a mount point (e.g. mkdir /mnt/usbdrive)

second, look at the message log (e.g. tail /var/log/message)

third, mount your drive (e.g. mount /dev/sda1 /mnt/usbdrive)

then you should be able to see your usb drive (e.g. ls /mnt/usbdrive)

If you can't figure out which device your usb is, try a few. It's likely to be sda1, sdb1, sdc1 etc depending upon which usb port you are plugged into. It you try to mount and get an error message like "not a valid block device" try another. The sda sdb etc is because the usb stuff uses scsi stuff for access. the 1 is to mount the first partition on the usb drive.

The assumption is that the usb drive is formatted as FAT which is automatically detected by mount.

malek_baklouti 04-15-2004 04:43 PM

thank you for your response, I'll try it now.. but I didn't get what the tail do exactly?

bryanl 04-15-2004 04:52 PM

tail /var/log/message will show the end of the message file. When you insert your USB drive, there will often be a log entry that shows what device (/dev/hda or whatever) has been detected. If you can find this log message then you know what device to mount.

Sometimes this message will show up on the console if you are logged in as root when you stick the drive in the USB socket.

malek_baklouti 04-15-2004 05:18 PM

the usbdriver hadn't been detected :o(( so there was no folder in the /dev
what is the problem in your opinion?
what shall I do?

JaseP 04-15-2004 09:22 PM

Seems like one of two possible things:

1) you failed to install the USB services like Hotplug... They should be installed...
2) Hotpug is there, but SCSI emulation is not,... install the SCSI related packages...

Linux uses SCSI emulation to talk to USB drives.

These reasons are generally why USB mass storage devices fail to install...

malek_baklouti 04-16-2004 10:00 AM

How to install the hotplug? I thing that it's not installed...

Phorem 04-16-2004 02:10 PM

If it's a standard installation from Mandrake, Red Hat or something like that, just try .....

modprobe hotplug

Then plug the usb drive in again and try doing the mounting stuff as mentioned above. But if it was a standard distro, Hotplug should be running already.

malek_baklouti 04-19-2004 12:34 PM

I tried as said in the last suggestion to install the hotplug, and when I write the command : " modprobe hotplug "

there is an error : " modprobe : can't locate module hotplug".

what shall I do?

tmillard 04-19-2004 04:09 PM

What distro. do you have?

Phorem 04-19-2004 04:10 PM

What distro are you using? That might help a bit.

If you're a nOOb, then i would try something like Mandrake. That automatically connects my wifes camera and my obscure camcorder so i can read the memory cards like a usb drive.

Everything eles listed above in this post should have worked by now. Seeing how your usb isn't working and i have no clue what distro you are using, there is no point in me blabing about a bunch of "possible fixes/problems" until there is a little more info on the table.

malek_baklouti 04-20-2004 11:50 AM

sorry but I didn't understand what's a "distro"?
what a "nOOb"?

I'm using redhat Linux 9.0...

Phorem 04-20-2004 01:01 PM

A distro is what kind of linux you are using - distribution. A noob is someone who has just started linux (or anything for that matter).

Try doing this in a console (and as root using su or sudo)......

lsmod - (look for a module called "sg")
If not, then "modprobe sg".

Next, type "dmesg" while your usb drive is plugin and turned on (if that is possible). There should be a message on the very last line about your usb storage device. If it's there, than you need to mount it.

Make a directory in /mnt/ called "hd" or whatever you want.

Now, this is the hard part. You need to find what device is being used for the hard drive. It might be /dev/sda or /dev/sg1 or a couple of others i think. It sucks, i know, but i don't know how to check (i did the tail /var/log thing but nothing was there) where the device is whithout a lot of hit and miss. If you find it, try this.....

mount /dev/sda(for example) /mnt/hd

That's all i got. Sorry. :-)

linuxfordumee 04-23-2004 09:43 AM

I just wanted to say (since I am a nOOb myself) that this worked perfectly for my Archos Jukebox and I am using Fedora Core 1. Thanks so much!

All times are GMT -5. The time now is 05:00 AM.