LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-16-2014, 11:34 PM   #751
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Rep: Reputation: Disabled

@deepa_2111
Hello

I want to know how to set more energy to CH and Base station node .
In file leach_test eq_energy is set 1. How to distribute unequal energy to nodes and CH

Also I want to calculate remaining energy of nodes . In which file I introduce energy model in order to see energy traces in trace file.
Please reply

Last edited by Aska123; 02-16-2014 at 11:40 PM.
 
Old 02-17-2014, 12:46 AM   #752
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Rep: Reputation: Disabled
Hello
@deepa

I want to know how to set different energy to nodes e.g. more energy to CH and less energy to member nodes.
How to see and set different energy level of nodes.

Thanks
 
Old 02-17-2014, 05:00 AM   #753
shegxyboy
LQ Newbie
 
Registered: Feb 2014
Posts: 4

Rep: Reputation: Disabled
@deepa 2111
Please help me, am unable to run my leach.nam, it displays nothings, is there a problem with my wireless.tcl or am doing somethings wrong, my leach.out and other came out good but the leach.nam that was generated didnt work, what should i do please?, am stuck here
 
Old 02-17-2014, 05:27 AM   #754
MedHad
LQ Newbie
 
Registered: Feb 2014
Posts: 2

Rep: Reputation: Disabled
Hi,

I configured leach successfully in ns2.34 and g++4.4. but it not show the complete output in leach.out. it only creates TDMASchedule0.txt file and stops. Help me in this regards.

Node 94 is DEAD!!!! - ns-leach.tcl
Node 95 is DEAD!!!! - ns-leach.tcl

At 1.0999999999999999: - mit/uAMPS/stats.tcl
Total Energy = 4.5493449382265103
Total Data = 0
Total Alive = 4

Help me, please.
 
Old 02-17-2014, 08:27 AM   #755
deepa_2111
Member
 
Registered: Apr 2011
Distribution: -
Posts: 185

Rep: Reputation: 268Reputation: 268Reputation: 268
Sorry .. I haven't used nam for LEACH, so I don't know ..

Quote:
Originally Posted by shegxyboy View Post
@deepa 2111
Please help me, am unable to run my leach.nam, it displays nothings, is there a problem with my wireless.tcl or am doing somethings wrong, my leach.out and other came out good but the leach.nam that was generated didnt work, what should i do please?, am stuck here
 
Old 02-17-2014, 08:29 AM   #756
deepa_2111
Member
 
Registered: Apr 2011
Distribution: -
Posts: 185

Rep: Reputation: 268Reputation: 268Reputation: 268
Please see the uamps.tcl file.
In the "leach-create-mobile-node" process, you can see how an energy of 200J is set to high energy nodes.

Quote:
Originally Posted by Aska123 View Post
Hello
@deepa

I want to know how to set different energy to nodes e.g. more energy to CH and less energy to member nodes.
How to see and set different energy level of nodes.

Thanks
 
1 members found this post helpful.
Old 02-18-2014, 12:34 AM   #757
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Rep: Reputation: Disabled
@deepa Thanks a lot

@shegybox

I am also working on leach.
I also try to run leach.nam but failed.

I know how to run wireless nodes in nam file.

If you want show me your wireless file for leach.nam . may be I can modify it to show node movements.
 
Old 02-19-2014, 04:54 AM   #758
keepwalking123
Member
 
Registered: Jan 2014
Posts: 52

Rep: Reputation: Disabled
hello..
i want to return some value from procedure..here is my code

Application/LEACH instproc nodesData {} {
puts "entering nodes data"
set t1 [temp]
puts "temp=$t1"
}
where temp is function which returns value

Application/BSApp instproc temp {} {
return "hello"
}
but is gives me error as

ns: _o122 recv 4 3 2008 3 , 0.10295415771443811: invalid command name "temp"
while executing
"temp"
(procedure "_o122" line 3)
(Application/LEACH nodesData line 3)
invoked from within
"$self nodesData"
(procedure "_o122" line 31)
(Application/LEACH recvDATA line 31)
invoked from within
"$self recvDATA $msg"
(procedure "_o122" line 22)
(Application/LEACH recv line 22)
invoked from within
"_o122 recv 4 3 2008 3 , 0.10295415771443811"

what is wrong in this code??please help me..
 
Old 02-19-2014, 07:10 AM   #759
deepa_2111
Member
 
Registered: Apr 2011
Distribution: -
Posts: 185

Rep: Reputation: 268Reputation: 268Reputation: 268
Hi Aska, a quick question.
In LEACH, nodes are stationary .. So what did you mean by node movement ?
I'm curious about the nam file .. If possible, can you upload a screenshot of the nam file ?

Quote:
Originally Posted by Aska123 View Post
@deepa Thanks a lot

@shegybox

I am also working on leach.
I also try to run leach.nam but failed.

I know how to run wireless nodes in nam file.

If you want show me your wireless file for leach.nam . may be I can modify it to show node movements.
 
Old 02-19-2014, 10:22 AM   #760
mittal_saurabhin
Member
 
Registered: Jul 2010
Posts: 45

Rep: Reputation: 0
@deepa #750

which blog r u talking about and where it has been pasted.....
please teellll
 
Old 02-19-2014, 02:07 PM   #761
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,383

Rep: Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599
# 760 , @mittal_saurabhin : Do not use text speak, please.
Not at all appreciated at LQ.
http://linuxsilo.net/docs/smart-questions_en.html
→ ""Write in clear, grammatical, correctly-spelled language.""

Generally : Please read the @deepa_2111 posts.

Ref. #750 : The link is incredibly easy to find ! Go one page back →
→ → #727 : http://ns2.blogspot.ca/
... Or a few posts up : #745.

-

Last edited by knudfl; 02-19-2014 at 02:17 PM.
 
Old 02-19-2014, 10:58 PM   #762
keepwalking123
Member
 
Registered: Jan 2014
Posts: 52

Rep: Reputation: Disabled
hello all, please tell me solution to my problem posted in #758.please i am really stuck there..waiting for responce..
 
Old 02-20-2014, 06:08 AM   #763
deepa_2111
Member
 
Registered: Apr 2011
Distribution: -
Posts: 185

Rep: Reputation: 268Reputation: 268Reputation: 268
Here are some reasons why you could be having an error : http://wiki.tcl.tk/1630.
Check your spaces and your alignment as well.

Try calling "temp" without a set (as shown in the examples in http://wiki.tcl.tk/463).


Quote:
Originally Posted by keepwalking123 View Post
hello all, please tell me solution to my problem posted in #758.please i am really stuck there..waiting for responce..
 
1 members found this post helpful.
Old 02-20-2014, 10:15 AM   #764
mittal_saurabhin
Member
 
Registered: Jul 2010
Posts: 45

Rep: Reputation: 0
sorry knudfl...... for using short abbreviations
 
Old 02-20-2014, 10:22 AM   #765
mittal_saurabhin
Member
 
Registered: Jul 2010
Posts: 45

Rep: Reputation: 0
@deepa @keepwalking

If possible, can you please provide me the tcl file for leach or higher versions so as to run and analyze LEACH......
else
can you please provide me the details of tcl files available in ex folder so that the same can be used for simulating LEACH..
 
  


Reply

Tags
leach, leach-warning50, ns2, ns2 ns234, pegasis


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ns:"error when calling class OldSim"&tclsh:"invalid command+child process exits abn." shojaru Linux - Newbie 0 03-05-2009 04:23 AM
labview stopped at "init tmp resource files" on FC4 baosheng Linux - Software 2 09-28-2007 11:02 AM
ORiNOCO WLAN card not working - "failed to allocate resource" hauneboo Linux - Laptop and Netbook 1 11-29-2005 09:08 AM
What "kernel opts" allow PC to power down with "turning energy off"? kornerr Linux - General 1 03-10-2005 12:07 PM
nvidia insmod: "Device or resource busy" w/GeForce 4 MX KeithSpook Linux - Hardware 4 03-03-2004 12:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration