LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-12-2013, 04:28 AM   #496
DeepaliDeshpande
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Rep: Reputation: Disabled
Leach


Knudfl ,
I am really facing very difficulty.Please i need ur help as my final dessertation is very close.
i have installed leach properly when i run leach_test/.test, leach.out file is been creating in leach_sims but it is totally empty.
Next i want to find remaining energy i.e initial-expended I have written code in stats.tcl for it but i dont know how to get result
for it as leach.energy is not getting change.
please it will be really very great if you help me as i have noticed total 33 pages of forum that u have helped many even iam new please consider
Thank u
 
Old 07-14-2013, 02:49 PM   #497
goldking123
LQ Newbie
 
Registered: Jun 2013
Location: Kanpur
Posts: 26

Rep: Reputation: Disabled
Respected Knudfl sir,

I am in critical situation. i got no error in leach.err file but i got incomplete output in leach.out. please help me. it is very urgent need for me. we have more confidence on linuxquestions.org and you. because you supported more than 100 users. so please help.

Quote:
Node 94 is DEAD!!!!
Node 95 is DEAD!!!!

At 1.0999999999999999:
Total Energy = 3.727532528144
Total Data = 0
Total Alive = 4

Simulation complete.

num_nodes is set 101
channel.cc:sendUp - Calc highestAntennaZ_ and distCST_
highestAntennaZ_ = 1.5, distCST_ = 222.8

Thanks in advance.

Last edited by goldking123; 07-15-2013 at 12:11 AM.
 
1 members found this post helpful.
Old 07-15-2013, 03:04 AM   #498
saeed.m
LQ Newbie
 
Registered: Apr 2013
Posts: 17

Rep: Reputation: Disabled
hi
when i try to run leach.tcl the following command

getopt $argc $argv

give me error.i don't know why this command became to failure please help.
error message in the below picture
Click image for larger version

Name:	Capture1.PNG
Views:	21
Size:	27.6 KB
ID:	12961
 
Old 07-15-2013, 03:36 AM   #499
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,383

Rep: Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599
# 498 .

"leach.tcl" is not a "simulation.tcl" file. Is a scenario file.
Please read 'leach.tcl' to know the text.

Other files that use 'leach.tcl' : $ cd mit/
Code:
$ grep -Rn leach.tcl *
leach-c.tcl:7:source uAMPS/ns-leach.tcl
uAMPS/sims/leach-c.tcl:7:source $env(uAMPS_LIBRARY)/ns-leach.tcl
uAMPS/sims/leach.tcl:7:source mit/uAMPS/ns-leach.tcl
uAMPS/sims/mit/leach-c.tcl:7:source uAMPS/ns-leach.tcl
uAMPS/sims/stat-clus.tcl:7:source $env(uAMPS_LIBRARY)/ns-leach.tcl
 
1 members found this post helpful.
Old 07-15-2013, 05:30 AM   #500
DeepaliDeshpande
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Rep: Reputation: Disabled
Sir iam waiting for ur reply
 
Old 07-15-2013, 05:55 AM   #501
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,383

Rep: Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599
# 500.

@ deepa_2111 can probably answer your questions. See post # 493.


Also : Please read the LEACH threads ...
http://www.linuxquestions.org/questions/tags/leach/

-
 
Old 07-15-2013, 08:34 AM   #502
goldking123
LQ Newbie
 
Registered: Jun 2013
Location: Kanpur
Posts: 26

Rep: Reputation: Disabled
Respected knudfl sir,

thank you for you support and help.
 
Old 07-15-2013, 01:53 PM   #503
deepa_2111
Member
 
Registered: Apr 2011
Distribution: -
Posts: 185

Rep: Reputation: 268Reputation: 268Reputation: 268
@ goldking, this output is correct.
Your simulation stops when no. of clusters < k (the value you set in your configuration file)


Quote:
Originally Posted by goldking123 View Post
Respected Knudfl sir,

I am in critical situation. i got no error in leach.err file but i got incomplete output in leach.out. please help me. it is very urgent need for me. we have more confidence on linuxquestions.org and you. because you supported more than 100 users. so please help.




Thanks in advance.
 
1 members found this post helpful.
Old 07-15-2013, 01:57 PM   #504
deepa_2111
Member
 
Registered: Apr 2011
Distribution: -
Posts: 185

Rep: Reputation: 268Reputation: 268Reputation: 268
@ Deepali,

Did you try all the steps mentioned in the earlier threads ? viz, changing the tcl files (including ns-default.tcl)? and the c/c++ file ?


Quote:
Originally Posted by DeepaliDeshpande View Post
Sir iam waiting for ur reply
 
1 members found this post helpful.
Old 07-16-2013, 04:35 AM   #505
DeepaliDeshpande
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Rep: Reputation: Disabled
Leach

Hi deepa_2111
yes i tried all but still my leach.out is showing nothing only displaying num_nodes is set 101.
Please deepa let me also know how leach.energy can be modified to display remaining energy instead expended.
Thanks in advance its really very very urgent
 
Old 07-16-2013, 05:29 AM   #506
goldking123
LQ Newbie
 
Registered: Jun 2013
Location: Kanpur
Posts: 26

Rep: Reputation: Disabled
Respected Knudfl sir and Deepa Mam,

I followed all the steps as you said. but i am unable to get same output as in the reference file (leach.out) and only one TDMAschedule file is created. please tell what are the other modifications i must do in the programs like max_dist is 86. please help me to create a valid nam file also.

Thanks in advance. how can i send my files to you for your verifications. please help me.

and also in leach.out it shows
Quote:
1: Warning!!! No Cluster Head ADVs were heard! - ns-leach.tcl
..
..
99: Warning!!! No Cluster Head ADVs were heard! - ns-leach.tcl

after these lines the nodes starts to dead.

Last edited by goldking123; 07-16-2013 at 05:31 AM.
 
Old 07-25-2013, 07:32 AM   #507
WSN routing protocol
LQ Newbie
 
Registered: Feb 2013
Posts: 1

Rep: Reputation: Disabled
how can i draw the result from leach.out

thanks
 
Old 07-26-2013, 02:45 AM   #508
kingrulez
LQ Newbie
 
Registered: Mar 2013
Posts: 18

Rep: Reputation: Disabled
Unable to run the nam file:

I am unable to load the nam files of leach, leach-c and pegasis.

Could you please help me to figured it out, and please take a look at the erros.

@ubuntu:~/ns-allinone-2.34/ns-2.34$ ns leach.nam
invalid command name "V"
while executing
"V -t * -v 1.0a5 -a 0"
(file "leach.nam" line 1)

Nam file contained:
V -t * -v 1.0a5 -a 0
W -t * -x 1000 -y 1000
A -t * -n 1 -p 0 -o 0xffffffff -c 31 -a 1
A -t * -h 1 -m 2147483647 -s 0

Best Regards,
KSR.
 
Old 07-26-2013, 03:06 AM   #509
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,383

Rep: Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599
# 508 .

Looks OK. $ ns : Is for a simulation with a tcl file.
You will of course have to use 'nam' for "out.nam" files:

$ nam <out>.nam
 
Old 07-26-2013, 06:50 AM   #510
kingrulez
LQ Newbie
 
Registered: Mar 2013
Posts: 18

Rep: Reputation: Disabled
Thanks for your kind response.

Best Regards,
KSR
 
  


Reply

Tags
leach, leach-warning50, ns2, ns2 ns234, pegasis


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ns:"error when calling class OldSim"&tclsh:"invalid command+child process exits abn." shojaru Linux - Newbie 0 03-05-2009 04:23 AM
labview stopped at "init tmp resource files" on FC4 baosheng Linux - Software 2 09-28-2007 11:02 AM
ORiNOCO WLAN card not working - "failed to allocate resource" hauneboo Linux - Laptop and Netbook 1 11-29-2005 09:08 AM
What "kernel opts" allow PC to power down with "turning energy off"? kornerr Linux - General 1 03-10-2005 12:07 PM
nvidia insmod: "Device or resource busy" w/GeForce 4 MX KeithSpook Linux - Hardware 4 03-03-2004 12:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration