LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-28-2013, 04:13 AM   #31
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641

# 30 .

No answers until you have replied to post # 28.

And you will have to check ns-allinone-2.26/ns-2.26/Makefile :
Line 37 : CC = gcc32
Line 38 : CPP = g++32

If any different from gcc32 / g++32 : Start from scratch.

-
 
Old 04-28-2013, 09:37 AM   #32
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Original Poster
Rep: Reputation: Disabled
I did
yum install \
gcc-c++ compat-gcc-34-c++ automake autoconf make libtool libXmu-devel patch

# yum install gcc32-3.2.3-1.sl5.i386.rpm
$you need to reboot the system
# yum install g++32-3.2.3-1.sl5.i386.rpm
$ you need to reboot the system.
when I reboot again i $export CC=gcc32 CXX=g++32 && ./install

I am not able to understand your question?
 
Old 04-28-2013, 10:43 AM   #33
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
# 30 .

And you will have to check ns-allinone-2.26/ns-2.26/Makefile :
Line 37 : CC = gcc32
Line 38 : CPP = g++32

If any different from gcc32 / g++32 : Start from scratch.

-
I checked Makefile. It was not gcc32/ g++ . It is cc and c++. But when I changed these to gcc32 / g++32

and $ export CC=gcc32 CXX=g++32 && ./install
$otcl configuration failed. Again I changed makefile to cc and c++ and ./install. otcl error gone. only sensornet error remains.
 
Old 04-28-2013, 10:47 AM   #34
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
# 31 .

Please open a terminal window, and type
1) which gcc32 <Enter>
2) which g++32 <Enter>

... to confirm that gcc32, g++32 are installed, and are in your PATH.
... And then please report the reply result of the two commands : in a new post.

-
 
Old 04-29-2013, 12:47 AM   #35
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Original Poster
Rep: Reputation: Disabled
: command not found
: command not found
[rohinisharma@localhost ~]$ which gcc32
/usr/bin/which: no gcc32 in (/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/rohinisharma/ns-allinone-2.34/bin:/home/rohinisharma/ns-allinone-2.34/tcl8.4.18/unix:/home:/home/rohinisharma/ns-allinone-2.29/bin:/home/rohinisharma/ns-allinone-2.29/tcl:/home/rohinisharma/bin:/home/rohinisharma/ns-allinone-2.34/bin:/home/rohinisharma/ns-allinone-2.34/tcl8.4.18/unix:/home/rohinisharma/ns-allinone-2.34/tk8.4.18/:/home/rohinisharma/ns-allinone-2.29/bin:/home/rohinisharma/ns-allinone-2.29/tcl)/home/rohinisharma/ns-allinone-2.29/nam-1.13/9/tk8.4.18/unix
[rohinisharma@localhost ~]$ which g++32
/usr/bin/which: no g++32 in (/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/rohinisharma/ns-allinone-2.34/bin:/home/rohinisharma/ns-allinone-2.34/tcl8.4.18/unix:/home:/home/rohinisharma/ns-allinone-2.29/bin:/home/rohinisharma/ns-allinone-2.29/tcl:/home/rohinisharma/bin:/home/rohinisharma/ns-allinone-2.34/bin:/home/rohinisharma/ns-allinone-2.34/tcl8.4.18/unix:/home/rohinisharma/ns-allinone-2.34/tk8.4.18/:/home/rohinisharma/ns-allinone-2.29/bin:/home/rohinisharma/ns-allinone-2.29/tcl)/home/rohinisharma/ns-allinone-2.29/nam-1.13/9/tk8.4.18/unix
[rohinisharma@localhost ~]$
 
Old 04-29-2013, 02:25 AM   #36
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
# 35 .
Quote:
/usr/bin/which: no gcc32 ..
/usr/bin/which: no g++32 ..
Means : You did not install the two packages.

Other ways of checking a package install :
$ rpm -qa <package-name>
$ rpm -qa | grep <name> ( Or part of name.)

$ rpm -qa gcc32 : Will reply with gcc32-3.2.3-1.sl5.i386
$ rpm -qa g++32 : Reply is : g++32-3.2.3-1.sl5.i386

Please do 1) $ cd Downloads/
( or wherever you keep the downloaded packages gcc32 and g++32.)
2) # yum install gcc32-3.2.3-1.sl5.i386.rpm
... Or 2a) # rpm -Uvh gcc32-3.2.3-1.sl5.i386.rpm
3) # yum install g++32-3.2.3-1.sl5.i386.rpm
... Or 3a) # rpm -Uvh g++32-3.2.3-1.sl5.i386.rpm

-
 
Old 04-29-2013, 02:58 AM   #37
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
# 35 .

Please do 1) $ cd Downloads/
( or wherever you keep the downloaded packages gcc32 and g++32.)
2) # yum install gcc32-3.2.3-1.sl5.i386.rpm
... Or 2a) # rpm -Uvh gcc32-3.2.3-1.sl5.i386.rpm
3) # yum install g++32-3.2.3-1.sl5.i386.rpm
... Or 3a) # rpm -Uvh g++32-3.2.3-1.sl5.i386.rpm

-
I want to ask that gcc32-3.2.3-1.sl5.i386.rpm and g++32-3.2.3-1.sl5.i386.rpm work with ubuntu 10.04 ?

I have refereed your's old post to install ns2.26 in ubuntu. I download these pacakages on desktop. But when I tried to install them
E:no package found.
 
Old 04-29-2013, 06:29 AM   #38
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Original Poster
Rep: Reputation: Disabled
On fedora 10

[root@localhost Download]# yum install gcc32-3.2.3-1.sl5.i386.rpm
Loaded plugins: refresh-packagekit
http://ftp.heanet.ie/pub/fedora-arch...ta/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
http://ftp-stud.hs-esslingen.de/pub/...ta/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
http://dl.fedoraproject.org/pub/arch...ta/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
http://mirror.cse.iitk.ac.in/fedora-...ta/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
http://ftp.tsukuba.wide.ad.jp/Linux/...ta/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
http://ftp.cuhk.edu.hk/pub/linux/fed...ta/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
Setting up Install Process
Examining gcc32-3.2.3-1.sl5.i386.rpm: gcc32-3.2.3-1.sl5.i386
Marking gcc32-3.2.3-1.sl5.i386.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package gcc32.i386 0:3.2.3-1.sl5 set to be updated
--> Processing Dependency: /bin/csh for package: gcc32-3.2.3-1.sl5.i386
--> Running transaction check
---> Package tcsh.i386 0:6.15-7.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
gcc32 i386 3.2.3-1.sl5 /gcc32-3.2.3-1.sl5.i386 9.7 M
Installing for dependencies:
tcsh i386 6.15-7.fc10 updates 473 k

Transaction Summary
================================================================================
Install 2 Package(s)
Upgrade 0 Package(s)

Total size: 10 M
Total download size: 473 k
Is this ok [y/N]: y
Downloading Packages:
http://mirror.cse.iitk.ac.in/fedora-...fc10.i386.rpm: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
http://ftp.tsukuba.wide.ad.jp/Linux/...fc10.i386.rpm: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
http://ftp.cuhk.edu.hk/pub/linux/fed...fc10.i386.rpm: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.


Error Downloading Packages:
tcsh-6.15-7.fc10.i386: failure: tcsh-6.15-7.fc10.i386.rpm from updates: [Errno 256] No more mirrors to try.

I was not connected to internet while installing packages. is this reason of error . Can ns2.26 not install on ubuntu 10.04. because on ubuntu I am connected to internet

Last edited by Aska123; 04-29-2013 at 06:37 AM.
 
Old 04-29-2013, 06:37 AM   #39
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Original Poster
Rep: Reputation: Disabled
rohini@ubuntu:~$ cd Downloads
rohini@ubuntu:~/Downloads$ sudo apt-get install gcc32-3.2.3-1.sl5.i386.rpm
[sudo] password for rohini:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package gcc32-3.2.3-1.sl5.i386.rpm
rohini@ubuntu:~/Downloads$

when I searched it in synpactic manager. These packages were not there.

Last edited by Aska123; 04-29-2013 at 06:41 AM.
 
Old 04-29-2013, 07:23 AM   #40
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
# 38 . I thought you were using CentOS 6 now ?

Fedora 10 is old. Please replace all /etc/yum.repos.d/fedora** with
a new file : fedora10.repo
Code:
[fedora10]
name=Fedora10-i386 
baseurl=http://archives.fedoraproject.org/pub/archive/fedora/linux/releases/10/Everything/i386/os/
enabled=1
gpgcheck=1

[fedora10-updates]
name=Fedora10-updates-i386
baseurl=http://archives.fedoraproject.org/pub/archive/fedora/linux/updates/10/i386/
enabled=1
gpgcheck=1
# 39 : rpm packages cannot be installed into Ubuntu.

-
 
Old 04-30-2013, 09:01 AM   #41
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Binary package "nrl-sensorsim-ns-2.26-1.sl6.i686.rpm", 2.7 MB
https://docs.google.com/file/d/0B7S2...it?usp=sharing
.. For CentOS 6.x, SL6.x, Fedora 12 and later,
providing /usr/local/bin/ns-nrl

A couple of good simulations : $ cd simulation_aids/ ;
$ tar xvf nsboids.tgz ; $ cd nsboids/
$ ns-nrl swarms.tcl ; $ nam swarmboids.nam
$ ns-nrl nsboids.tcl ; $ nam boids.nam

-

Last edited by knudfl; 04-30-2013 at 10:11 AM.
 
Old 04-30-2013, 10:33 AM   #42
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Ubuntu 10.x compilers for ns-allinone-2.26: gcc33-compat-3.3.3-sle10_i386.deb
https://docs.google.com/file/d/0B7S2...it?usp=sharing
g++33-compat-3.3.3-sle10_i386.deb
https://docs.google.com/file/d/0B7S2...it?usp=sharing
Required is : sudo apt-get install libstdc++5

Ubuntu 10.xx : export CC=gcc-3.3 CXX=g++-3.3 && ./install
Result, binary package nrl-sensorsim-ns-2.26-ubuntu10_i386.deb, 3.4 MB
https://docs.google.com/file/d/0B7S2...it?usp=sharing
providing /usr/local/bin/ns-nrl

Probably the best result : All phenom**.tcl will create phenom**.nam ,
and phenom14.tcl : simme.nam + phenom14.nam .

-
 
Old 04-30-2013, 03:28 PM   #43
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Fedora 10 ( Or any Fedora, versions 6 .. 18 ) + CentOS 5, SL 5 :
Binary package, nrl-sensorsim-ns-2.26-1.sl5.i386.rpm, 3.4 MB
https://docs.google.com/file/d/0B7S2...it?usp=sharing
Required : # yum install libstdc++-33

Building nrlsensorsim on Scientific Linux 5, CentOS 5, old Fedora with gcc-3.3.3 :
export CC=gcc-3.3 CXX=g++-3.3 && install

gcc-3.3.3 → gcc33-compat-3.3.3-1.sl5.i386.rpm
https://docs.google.com/file/d/0B7S2...it?usp=sharing
g++-3.3.3 → g++33-compat-3.3.3-1.sl5.i386.rpm
https://docs.google.com/file/d/0B7S2...it?usp=sharing
Required : libstdc++-33

-
 
Old 05-01-2013, 02:09 AM   #44
Aska123
Member
 
Registered: Apr 2013
Posts: 197

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
# 38 . I thought you were using CentOS 6 now ?

Fedora 10 is old. Please replace all /etc/yum.repos.d/fedora** with
a new file : fedora10.repo

-
[rohinisharma@localhost etc]$ yum.repos.d/fedora**
bash: yum.repos.d/fedora-rawhide.repo: Permission denied
[rohinisharma@localhost etc]$

how to replace these files?
 
Old 05-01-2013, 02:53 AM   #45
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
# 44 .

1) cd /etc/yum.repos.d/
2) su
3) mkdir backup
4) mv fedora* backup/
5) vi fedora10.repo
... and then add the repo text (post # 40) to the empty file.

Easier ( Instead of 5) ) : Use the attachment : fedora10.repo.txt
a) mv fedora10.repo.txt fedora10.repo
b) su
c) cp fedora10.repo /etc/yum.repos.d/
-
Attached Files
File Type: txt fedora10.repo.txt (302 Bytes, 14 views)
 
1 members found this post helpful.
  


Reply

Tags
nrlsensorsim, ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install both ns2.28 and ns2.34 versions on ubuntu 10.04? popoaung Linux - Software 3 06-10-2013 04:52 PM
[SOLVED] how to install NS2 in Fedora 9 ? sange Linux - Software 2 01-23-2012 04:00 AM
how to install NS2.34 in fedora 14 naren123.k Linux - Software 9 03-12-2011 03:20 AM
How to install NS2 on fedora 11????? liban779 Linux - Software 5 03-04-2011 06:46 AM
how to install ns2 in fedora-5? salady86 Linux - Newbie 3 03-14-2008 08:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration