LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   How to install Nessus 3.0.6 on Slackware 12? (https://www.linuxquestions.org/questions/linux-software-2/how-to-install-nessus-3-0-6-on-slackware-12-a-598736/)

ninguno1986 11-11-2007 03:49 AM

How to install Nessus 3.0.6 on Slackware 12?
 
Hello, before a long time I used Nessus without problem, after several years (today) I go to nessus.org and I notice that there r only installers for redhat,fedora and debian, no more tar.gz or tar.bz2.
Anyway looking in google I found several tutorials explaining how to install Nessus 3.0.1, I follow all the steps and nothing, someone who already installed it, can tell me how to?
Ill paste the tutorial I followed, I just changed the versions, instead try with 3.0.1 i tried with 3.0.6, skackware 12 and last version of client too:


A simple guide on how to install Nessus on slackware 10.2

As you may know "Tenable" doesn't provide native packages for Slackware, so we must do some tricks in order to run it.

First go and grab the package for fedora core 4 (that's what I'll be using for this example).When you are done you have to convert this package to tgz , this is done by simply using the "rpm2tgz" utility, so you do something like:
"rpm2tgz packagename.rpm". Then you should wait for a while ... after everything is done you must install the package:
"installpkg packagename.tar"

After the package is installed, it places its files in /opt/nessus dir.Now you should do the following things:
1.Update the berkeley db library version ([linuxpackages/download.php?id=8485)
2.Then you must copy all files from /opt/nessus/lib to /usr/local/lib and run the ldconfig utility in order to update the library list.(Only the files, not the "nessus" subfolder)
3.Now it's time for some symbol linking:
3.1 Go into /usr/lib dir and execute the following commands:
ln -s libcrypto.so.0 libcrypto.so.5
ln -s libssl.so.0 libssl.so.5
ln -s libdb4-4.so libdb-4.3.so

After you've done this you may try and run nessus-add-first-user, then nessus-mkcrt, and finally nessus -D

I wish you luck.And I do not take any responsibility if you crash your system or something (Most probably it won't happen)

Author: LordDoskias with a little help from iddqd
You can contact me on irc.freenode.net @ ##slackware



Thank you very much for your time.

MS3FGX 11-11-2007 05:36 AM

What exactly happens when you try to run it? And do you get errors during any step of the process?

ninguno1986 11-11-2007 05:39 AM

hi
 
Well, now I uninstalled, but when I tried to do the mkcert it said I have not nessud (despite it was in /opt/nessus/sbin/nessusd according with the command "which nessusd" or "whereis")...also a problem of libraries, now I suppose the versions of the libraries may be different (they should), and maybe it caused the problem because when I did ln i did exactly as its wrote in the tutorial...
thnx for ur reply.


All times are GMT -5. The time now is 02:47 AM.