LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-10-2006, 02:22 AM   #1
sickdude
LQ Newbie
 
Registered: Mar 2005
Distribution: red hat *, fedora core *, gentoo, slackware, ubuntu
Posts: 27

Rep: Reputation: 15
Question how to install libgcj.so.5


ok the thing is that im trying to install pdftk on a fedora cora 3 machine.

when i try to install the rpm i get this

rpm -i pdftk-1.12-0.fdr.1.3.i386.rpm
warning: pdftk-1.12-0.fdr.1.3.i386.rpm: V3 DSA signature: NOKEY, key ID ff6382fa
error: Failed dependencies:
libgcj.so.5 is needed by pdftk-1.12-0.fdr.1.3.i386

So i found the libgcj.so.5 file on the internet, but now i dont really know what to do with it. how do i install this file on the system?

thnx ion advance dudes and dudettes
 
Old 05-10-2006, 02:51 AM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
Is the file you downloaded on the internet an rpm? If not, you need to install the libgcj rpm for Fedora Core 3.
 
Old 05-10-2006, 03:13 AM   #3
sickdude
LQ Newbie
 
Registered: Mar 2005
Distribution: red hat *, fedora core *, gentoo, slackware, ubuntu
Posts: 27

Original Poster
Rep: Reputation: 15
no the libgcj.so.5 is not een rpm, because when i install that rpm it asks for 6 more dependencies
 
Old 05-10-2006, 03:26 AM   #4
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
Quote:
Originally Posted by sickdude
no the libgcj.so.5 is not een rpm, because when i install that rpm it asks for 6 more dependencies
You need to install the libgcj rpm and all other rpms that are dependencies of libgcj. Extracting individual files from an rpm and placing it somewhere on your system won't necessarily resolve your problem because libgcj.so.5 won't work properly without other files from the libgcj rpm.
 
Old 05-10-2006, 03:43 AM   #5
sickdude
LQ Newbie
 
Registered: Mar 2005
Distribution: red hat *, fedora core *, gentoo, slackware, ubuntu
Posts: 27

Original Poster
Rep: Reputation: 15
ok thnx dude, i did a apt-cache search and i found the package, so i did a install and then de rpm -i pdftk

worked like a charm

thnx loads
 
  


Reply

Tags
how, install


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libgcj-java-placeholder.sh and Java captainObvious Linux - General 6 07-25-2008 01:42 AM
the problem of libgcj winpro Linux - Newbie 2 08-28-2005 01:18 PM
How do I re-install an operatingsystem? Corrupted install. Yast wont load. URGENT.thx CrewXp SUSE / openSUSE 5 05-09-2005 12:07 AM
Problem with GCC 3.4.3 and libgcj Draco098 Linux - Software 2 03-01-2005 07:21 AM
[SOLVED] How to run Sun JDK 1.5 without conflict from libgcj? rhimbo Linux - Software 1 12-08-2004 06:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration