LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-07-2004, 10:40 AM   #1
jmg1894
LQ Newbie
 
Registered: Jun 2004
Posts: 16

Rep: Reputation: 0
how to install kernal-source code?


I need help installing new source code in Red hat Linux 9.0. I am installing a openswitch12 card which will be an IVR. In order to install the drivers for the card I need the kernel source and a complete compiling system installed. I installed the correct source file after that I get an error
gcc>= 2.96-98 is needed by kernel-source 2.4.20-8
What does this mean? and how can I fix this?
 
Old 06-07-2004, 10:43 AM   #2
zeropash
Member
 
Registered: Apr 2003
Location: Bangalore,India
Distribution: FC2, RHES, RH9, FC3, FC1, Slackware 3.0
Posts: 208

Rep: Reputation: 30
it simply means that you need to install the 2.96-98 or later versions of gcc.
download the same and install it
 
Old 06-07-2004, 10:44 AM   #3
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
It's complaining that you compiler (gcc) is too old. You need to update it. I suppose the easiest way is to find an rpm for it.

I am using gcc 3.3.2 for instance, and it would seem that yours is older than 2.96
 
Old 06-07-2004, 10:46 AM   #4
jmg1894
LQ Newbie
 
Registered: Jun 2004
Posts: 16

Original Poster
Rep: Reputation: 0
Where would I find this compiler? On the cd with Red Hat? Does it matter what version as long as its higher than 2.96?
 
Old 06-07-2004, 11:00 AM   #5
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
http://fr.rpmfind.net/linux/rpm2html...mit=Search+...

You might as well install the latest and greatest: 3.3.2 for redhat is down about 15 lines.

NOTE: you will probably need to update your entire toolchain...ie: make, autoconf, binutils.

If rpm complains when you update your gcc then find the dependancies you need on www.rpmfind.org and install them.

Last edited by bulliver; 06-07-2004 at 11:05 AM.
 
Old 06-07-2004, 12:56 PM   #6
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
Quote:
Originally posted by bulliver

You might as well install the latest and greatest: 3.3.2 for redhat
hold on there ...
i think just get the exact compiler
2.96-98 the package manager says.
the more modern compilers are not backward compatable with binaries made with the older ones.......
if you install 3.3.2
or even 3.0
the stuff it compiles may be broken.
also you can only / should only compile a kernel module with exactly the same compiler used to compile the kernel itself !
it won't let you do otherwise
 
Old 06-07-2004, 01:29 PM   #7
jmg1894
LQ Newbie
 
Registered: Jun 2004
Posts: 16

Original Poster
Rep: Reputation: 0
When I run the new 3.2.2-5 rpm file I now get the following message:
Failed
binutils>= 2.12.900.7-1
cpp= 3.2.2-5
blibc-devel>= 2.2.90-12

Does this mean I have to upgrade these before the 3.2.2-5 will work?
 
Old 06-07-2004, 01:34 PM   #8
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 60
Quote:
bullriver said

NOTE: you will probably need to update your entire toolchain...ie: make, autoconf, binutils.

If rpm complains when you update your gcc then find the dependancies you need on www.rpmfind.org and install them.
Quote:
jmg1894 said:

When I run the new 3.2.2-5 rpm file I now get the following message:
Failed
binutils>= 2.12.900.7-1
cpp= 3.2.2-5
blibc-devel>= 2.2.90-12

Does this mean I have to upgrade these before the 3.2.2-5 will work?
that was already told to you ...
 
Old 06-07-2004, 06:06 PM   #9
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
Quote:
Originally posted by jmg1894
When I run the new 3.2.2-5 rpm file I now get the following message:
Failed
binutils>= 2.12.900.7-1
cpp= 3.2.2-5
blibc-devel>= 2.2.90-12

Does this mean I have to upgrade these before the 3.2.2-5 will work?
yes - track down and install at least those version numbers or newer. welcome to dependency hell you may want to run some searches on an app called "apt" (or maybe "apt-rpm"?) - it assists with dependency checking, etc. good luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernal Source Code douginky Mandriva 2 12-20-2004 03:28 PM
how to install kernal source reshma Linux - Newbie 3 01-15-2004 07:36 PM
Mandrake 9.2 Kernal source code Penguin666 Linux - General 9 11-19-2003 07:56 PM
Linux newbie needs help configure kernal source code sabaka Linux - Software 3 09-12-2003 07:36 PM
Kernal source code andrewtc Linux - Software 6 04-25-2003 02:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration