LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-21-2005, 01:33 PM   #1
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Rep: Reputation: 30
How to get POP Gmail to work with Evolution?


Hello -

I am trying to set up POP e-mail with a gmail account. I am using Evolution 1.2.2. I switched the proper setting at gmail and set up an account in Evolution. However, Evolution won't go through. I'm wondering if Evolution doesn't use the proper SSL port. How can I check which SSL port Evolution is using?

Has anyone else managed to get POP gmail working with Evolution? If so, how did you do it?

Thanks for any help.
 
Old 03-22-2005, 06:02 AM   #2
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 47
the thing is gmail uses diffrent pop and smtp port

pop port : 995

smtp port : 587

http://gmail.google.com/support/bin/...3284&topic=194
 
Old 03-22-2005, 09:25 AM   #3
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
Thanks for the reply.

I know Gmail uses different ports. My problem is, how do I get Evolution 1.2.2 to use those ports? I have poked around in Evolution and can't seem to find anyplace where I can change the ports. There must be some way, but I am stumped.

Of course I could solve my problem by using a different e-mail client, but I've been using Evolution for some time to get my other pop e-mail and would rather not switch. Any help with Evolution would be much appreciated.
 
Old 03-25-2005, 04:29 AM   #4
slysy
LQ Newbie
 
Registered: Mar 2005
Posts: 1

Rep: Reputation: 0
You need to enter a colon followed by the port number after the server address.

pop.gmail.com:995
smtp.gmail.com:465
 
Old 03-25-2005, 09:44 AM   #5
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
It worked

Slysy -

Thank you very much. That was exactly the information I needed. I put it into Evolution and the mail downloaded from the Gmail server. It did give me a message saying the Gmail certificate was bad (in more words) but I said accept it anyhow.

Not sure why Evolution said the certificate was bad. I can download my mail from the Gmail server now but sending gives me an error saying the server requires authentication (I have evolution set to use authentication but I think since it considers the certificate bad it doesn't use it or something)

If anyone has any information on this further problem I would appreciate hearing.
 
Old 03-25-2005, 12:29 PM   #6
Jimbo99
Member
 
Registered: Nov 2003
Distribution: Ubuntu 7.04
Posts: 241

Rep: Reputation: 31
I am using evolution with my gmail account and i wasn't required to put in the port information. I'm using version 2.0.4 of Evolution.
 
Old 03-25-2005, 01:41 PM   #7
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
Version

I am using version 1.2.2. Most likely your newer version is different/improved.

In any case, putting in the port numbers has allowed me to access the account. I can get mail I just can't send, I think, because Evolution said the certificate was bad. Why Evolution said that, I don't know. But that is where my problem has progressed too.
 
Old 03-26-2005, 03:48 PM   #8
mybuffalo
LQ Newbie
 
Registered: Mar 2005
Distribution: Ubuntu Warty
Posts: 2

Rep: Reputation: 0
I'm using Evolution 2.0.2.

I followed the suggestion above and it is working fine. In the sending mail tab, did you set the 'Use Secure Connection (SSL)' on?
 
Old 03-26-2005, 05:29 PM   #9
Rundi
Member
 
Registered: Jun 2003
Location: USA
Distribution: Ubuntu
Posts: 169

Original Poster
Rep: Reputation: 30
messed up

The error message is: "MAIL FROM response error: Authentication Required"

But . . .

I already have "use SSL connection: always"

and

Server requires authentication.

Like I said previously, the first time I tried to send over the gmail account it told me the Gmail SSL certificate was bad and asked if I still wanted to accept . . . I said yes, but since then I have not been able to send e-mail.

I don't know why Evolution said the certificate was bad, but I'm thinking I need to scrub out the SSL certificate information from my Evolution and have it get it from Gmail again.

How would I go about removing this "bad" certificate from Evolution?
 
Old 06-24-2005, 12:40 AM   #10
jabbott
LQ Newbie
 
Registered: Jun 2005
Distribution: Fedora Core 4
Posts: 2

Rep: Reputation: 0
I am using Evolution 2.2.2, I have read this post and tried specifying the port numbers as suggested, I have configured it to always use a secure connection, etc... but I still can't get/send Gmail with evolution. Any other suggestions?

With the certificates, you ought to be able to go to Edit->Preferences->Security and delete the certificate.
 
Old 06-24-2005, 12:54 AM   #11
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Sending and receiving gmail using Mozilla Mail or Mozilla Thunderbird works just fine. Why you need a fancy program like Evolution to handle e-mail?
 
Old 06-24-2005, 11:17 AM   #12
jabbott
LQ Newbie
 
Registered: Jun 2005
Distribution: Fedora Core 4
Posts: 2

Rep: Reputation: 0
I would like to make it work, since it should. Also I like having one place to go to see a calander, mail, tasks, etc... I know Mozilla has Thunderbird and Sunbird, but that seems like just as much work getting them to work like I want as making Evolution work.
 
Old 12-17-2008, 02:11 PM   #13
unixer12
LQ Newbie
 
Registered: Dec 2008
Posts: 4

Rep: Reputation: 0
Hi all

I registered simply to post my solution to this annoying problem.

I have Evolution 2.22.31 on FC9. I kept getting the bad certificate dialog and managed to solve the problem by importing the Thawte root certificates from www!thawte!com/roots/ (first post). The ZIP contains a file "Thawte Server Roots" which contains the Premium Server cert called "ThawtePremiumServerCA.cert".

To import this use edit>preferences>certificates>Authorities Tab>Import; locate the file; tick the "Trust to identify websites" tab

Whoo! No more problems because Evolution can validate the certificate sig against an authority.

God knows why Evolution isn't bundled with common CA certs (which I presume Thunderbird is?)

Anyway, I hope this helps people as frustrated as I was!

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hotmail pop settings for evolution email siphi Linux - Newbie 5 05-14-2011 03:42 AM
Gmail and Evolution jorisb Linux - Software 1 10-15-2005 01:34 PM
Set proxy in evolution mail client for gmail phamtranquocvie Linux - Software 8 06-13-2005 02:33 AM
can't access gmail pop servers -- help! opioid General 5 11-15-2004 02:53 PM
ximian evolution POP problems cowboy_ein Linux - Software 2 05-11-2003 03:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration