LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-16-2016, 12:28 AM   #1
watchintv
LQ Newbie
 
Registered: Oct 2016
Posts: 22

Rep: Reputation: Disabled
How to get arpspoof working correctly


I'm having trouble using arpspoof, part of dsniff...

I have tried a variety of combos of the following:

arpspoof -i wlp2s0 -t 192.168.0.1 192.168.0.103
arpspoof -i wlp2s0 -t 192.168.0.103 192.168.0.1

with the addition of -r flag. But nothing is working. Basically what happens is all my internet dies, the target machines and my host machines. I do turn on IP forwarding in linux too. I cant capture with driftnet. Is there a full proof guide on how to use this software? Or am I doing something wrong?

It seems like after doing som reading that the newest version may be flawed somehow? Can anyone confirm this?

Last edited by watchintv; 10-16-2016 at 01:14 AM.
 
Old 10-16-2016, 04:01 PM   #2
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
Rather than arpspoof, I would rather arpread (that is my invented command, of course) of the OSI layer.

Just my 2cents.
 
Old 10-16-2016, 06:49 PM   #3
watchintv
LQ Newbie
 
Registered: Oct 2016
Posts: 22

Original Poster
Rep: Reputation: Disabled
I've checked my ARP table on the target machine and it appears to have changed to the correct MAC address for its gateway (my attacker machine), but I still can't get any internet out of the target machine. The target is a Windows Vista computer. I'??ve turned on ip_forwarding too. What could be the issue?

Also, thanks for your reply, I'll take a look. Where exactly to get arpread at?

Thanks
 
Old 10-16-2016, 08:12 PM   #4
watchintv
LQ Newbie
 
Registered: Oct 2016
Posts: 22

Original Poster
Rep: Reputation: Disabled
Here's the weird thing. I guess I've got it to work correctly, meaning the target machine is pinging fine. And I have internet on my host machine. The problem arises when I run driftnet. It immediately blocks all internet on target and host machine. Why could that be?

Is there another sniffer tool I can use?

I even tried Wireshark and it does the same. It stops all internet on target and host machine. I don't believe the router is affected.

Last edited by watchintv; 10-16-2016 at 08:32 PM.
 
Old 10-16-2016, 10:33 PM   #5
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
What is driftnet, what is ARP? What its correlation with IP? I would rather know the answers to these questions (except driftnet, which I have absolutely no idea) than learning how to "spoof".
 
Old 10-17-2016, 11:32 AM   #6
watchintv
LQ Newbie
 
Registered: Oct 2016
Posts: 22

Original Poster
Rep: Reputation: Disabled
So I think I figured out the problem, but I'm not sure. It seems like when I enter the interface into promiscuous mode the packets don't get forwarded and the target machine stops pinging. Can anyone else confirm if I have the interface in promiscuous mode that ip forwarding does not work?

Or could it be that my computer simply can't handle the packets being sent (it seems I have a lot of network traffic) and therefore the packets are being dropped?

Last edited by watchintv; 10-17-2016 at 11:39 AM.
 
Old 10-17-2016, 01:54 PM   #7
watchintv
LQ Newbie
 
Registered: Oct 2016
Posts: 22

Original Poster
Rep: Reputation: Disabled
Ok, so I think the packets were being dropped due to high network activity. I've lowered my network activity and I can ping from my target machine fine.

Thanks for everyone's help, and if you think it may be something else then please let me know.

Thanks again,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
arpspoof scenario does not work Barade Linux - Security 1 10-15-2016 02:26 AM
LXer: TuxCut - A Tool To Protect Linux Against arpspoof Attacks LXer Syndicated Linux News 0 09-12-2016 11:51 AM
arpspoof hangs ballsystemlord Linux - Software 1 05-30-2015 08:45 AM
[SOLVED] C algorithm not working correctly. madsovenielsen Programming 5 03-02-2012 03:02 PM
ettercap vs. arpspoof kirmet Linux - Networking 0 11-03-2005 08:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration