-   Linux - Software (
-   -   How to fix LILO? (

2dope 05-15-2004 05:05 PM

How to fix LILO?
I have Mandrake 10, recently I was playing with KDE 3.2.2 configuration and I messed up my LILO. Since I dual-boot, it only displays "LILO 22.8.5 loading windows" and boots into windows xp. I tried booting the Mandrake CD and going into "rescue" mode but fixing the boot loader doesn't do anything. I should mention taht I only had 'windows" and "linux" in the boot menu. Any way to make it work again? I know I should probably edit /etc/lilo.conf and run /sbin/lilo but how do I boot linux first?

rose_bud4201 05-15-2004 05:13 PM

Do you have a linux boot disk? If not, get one ( :)

Boot using the disk, then create a directory ('mkdir my_root_dir'), mount your linux root partition on it ('mount -t ext3 /dev/hda1 my_root_dir', if your / partition is on /dev/hda1 and it's ext3 formatted), chroot to the mount point ('chroot my_root_dir'), and from there you can edit lilo.conf and re-run /sbin/lilo.


michaelk 05-15-2004 07:44 PM

You can use Mandrake's rescue mode the same way. Just select to mount the partitions and go to console mode.

2dope 05-15-2004 09:13 PM

thanks to both of you guys, fixed it :)

All times are GMT -5. The time now is 06:35 PM.