Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 01-18-2009, 05:15 PM   #1
Registered: Jun 2008
Location: St.-Petersburg, Russia
Distribution: (B)LFS, Ubuntu, SliTaz
Posts: 403

Rep: Reputation: 51
How to enable hardware acceleration for all graphic (including 2D) output in X Window

Many programs seem to be very slow on 2D graphics output, e.g. on implementing transparency, scrolling, etc..
How can i make all (or most of) the calls to graphic libraries use OpenGL?
I read about cairo's support of output to OpenGL context in wikipedia, and found out that i need glitz to use this feature. I installed glitz and then tried to compile cairo with --enable-glitz command line argument for configure script. configure says:
--- The glitz surface backend feature is still under active development and
--- is included in this release only as a preview. It does NOT fully work yet
--- and incompatible changes may yet be made to glitz surface backend
--- specific API.
Does this mean cairo is going to use its own version of glitz, included in cairo's package, instead of using already installed one? If yes, how can i then make cairo use really working glitz?

Or, maybe glitz for cairo doesn't make much sense to speeding up 2D graphics in X server? I also read about Xgl in wikipedia, but in that article there was a link to AIGLX... Now with all this info i'm confused with this topic... Maybe, nothing of mentioned above would solve my task? What could be the solution then?
Old 01-21-2009, 01:19 AM   #2
Senior Member
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,552

Rep: Reputation: 103Reputation: 103
I think you are looking in the wrong place.

I had much the same problem with slow 2D performance on my older AGP based linux system. It had a Nvidia FX5200 card on an AGP slot, I solved the problem by loading the binary closed-source Nvidia driver onto that system. 2D performance was fixed after this step.

I suspect your problem is much the same, i. e. the X windows driver for your card is using software only, with no acceleration because no applicable firmware driver is loaded for your display card. That is why it is so slow...
Old 01-22-2009, 11:02 AM   #3
Registered: Jun 2008
Location: St.-Petersburg, Russia
Distribution: (B)LFS, Ubuntu, SliTaz
Posts: 403

Original Poster
Rep: Reputation: 51
I use nVidia proprietary driver version 173.08, there's no problem in driver's hardware acceleration support - i play 3D games at very high frame rate, video card is not old also - GF8800.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
3D acceleration in ATI graphic card brevleq Linux - Hardware 12 11-17-2008 10:08 AM
Setting up wifi graphic acceleration steelz Linux - Newbie 4 01-17-2008 08:48 AM
Detecting 3D acceleration support for Graphic Device kushalkoolwal Debian 5 10-08-2005 01:20 PM
Can't enable 3D hardware acceleration. daedalusonlinux SUSE / openSUSE 20 03-20-2005 09:42 PM
How do I enable 3D hardware acceleration in Mdk 9.1? Mackan Mandriva 4 11-23-2003 05:25 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:15 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration