LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-11-2006, 03:52 AM   #1
kdingo00
LQ Newbie
 
Registered: Nov 2006
Location: Seattle, WA
Posts: 1

Rep: Reputation: 0
How to disable autocomplete in KDE?


Hi, I'm using SUSE 10.1 with KDE, and I don't know how this little "feature" turned on, but it is now and is annoying the heck out of me.

It is some autocomplete feature in KDE and it makes inputting into web forms incredibly hard, as with commands in Konsole, and prevents me from entering passwords in Konsole.

To be specific in web forms, whatever I input in webforms is underlined with a red line, on a word-by-word basis. If I am typing my username in a field, for example, my username is underlined, and when I hit TAB, I get some autocomplete popup, and whatever I had typed is replaced by the first entry in the autocomplete popup. If instead of hitting TAB and I click into the next field for my password, the entire username is erased. Then I start typing into the password field and it appears there are already "*"s in the field. The characters from the previous field was moved over!

The same thing happens in the Konsole, except the red line is replaced with a green background. And I cannot type any sort of password, whether using su, sftp, etc.

I assume this is a KDE functionality, since the popup matches KDE's UI.

I'll post screenshots, but apparantly I need to have two more posts in my name.

Additionally, this affects non-KDE applications, such as xterm and Opera.
 
Old 11-12-2006, 01:05 PM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
I might be wrong but sounds like the KDE's "integrated spell checker". Can't remember the name of it, but if you do
Code:
ps -e | less
you'll probably see it (it's name should alarm you). Kill the process and see if it helps:
Code:
killall <processname>
if it did, then find out how to disable the feature. I didn't find such a button in KDE, nowhere to be exact, and in the end I just added it to a script that got run when I logged in, which killed the process. Don't know why they've enabled it in KDE if one can't disable it -- but a warning, I was using a Kubuntu KDE which is not exactly the original KDE, it has some small changes in it.

On web forms, right-click the field and see if there is an option to turn the spell checking off. It only works for that one time, I guess, but helps for a moment.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i disable autocomplete in firefox imagreg Linux - Software 3 06-12-2004 09:35 PM
openoffice spreadsheet questions: disable autocomplete, soft line-break and bugreport codec Linux - Software 0 04-28-2004 05:10 PM
[REDHAT KDE] Disable KDE boot? Apache down after 10min losing monitor signal bjwesselink Linux - Software 2 08-11-2003 01:52 PM
autocomplete figadiablo Linux - General 6 03-13-2002 04:19 PM
autocomplete marksstroud Linux - Newbie 1 11-11-2001 01:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration