-   Linux - Software (
-   -   How might I restore kmail folders/mail/settings from a "badly" saved "home"? (

deh6 03-04-2008 05:18 PM

How might I restore kmail folders/mail/settings from a "badly" saved "home"?
I would like to recover my kmail settings, mail, etc., but my saved file has some problems.

The sequence was-- Suse 10.2 locked up during a driver installation and didn't work after power-down/up. So I figured maybe a Suse 10.3 upgrade would clean it up. All sorts of problems.

First my system backup turned out to be no good.

I then tried a saving the whole system in its current semi-broken state to a new external drive. I *think* I did a cp -pr source dest. The result is that "/home" is available, but the owner and permissions appear incorrect.

I tried copying the saved "/home" directory from the external drive to a new installed Suse 10.3. The desktop then failed. Reload the Suse 10.3 and try copying ".kde" directory in. Kmail said that configurations et al. couldn't be written. Realizing that permissions and owners was off I tried doing a chmod 666 and chown. No luck.

Any ideas of what to do?

Brian1 03-04-2008 05:52 PM

Not used kmail in a long time but under the .kde is of the backup there should be something for it. Then maybe a .kmail for email or it may not be hidden. If not the same user then use the commands ' chown -R owner directory ' to change ownership to you. Then the same for ' chgrp -R owner directory ' for groupship to you. Then you should be able to copy over and replace of existing directories exist.


deh6 03-04-2008 07:42 PM


Thanks for the response. Yes, I did that. Copying .kde resulted everything on the desktop disappearing, and I was unable to launch anything, including a terminal window (so I had to reload the system).

There seems to be more to problem than copying .kde after making the owner and permissions changes. Perhaps something in some systems directory(?)

Brian1 03-05-2008 05:43 PM

It can depend on the version of kmail or any other app related to files under .kde. If you have a newer version of something than what is installed on the second it may not under stand the older format of files. Normally during a app upgrade if configs change they usually change between those versions. Just a possible idea.

I would not copy the entire .kde since it is info on several apps. If one config is started and the base app is not it may make it unstable.


deh6 03-06-2008 03:52 PM


Good thought. It's doubtful that versions are the problem. The old one would have been no earlier than 3.5.5 R45 and the new one is 3.5.7 R72.6.

What I haven't found is where the email is stored.
In the new installation I find it under the directories (for each folder) under:

In the old "stuff that was saved" I don't find a mail directory under kmail.

I doubt that it got erased, but on the other hand... The system crash was one where it locked up when Suse 10.2 Yast was writing the system configuration, after making some changes to the network cards. Rebooting the system had some problems, (e.g. it had reversed the drivers for the two network cards and AppAmor(sp?) didn't come up during bootup, as well as a couple of other things), but I did check the email program as a test to see of the network was working (which it was not). After trying a bunch of things, the details I now forget, I decided that maybe the best solution would be upgrade to reinstall, upgrading to, Suse 10.3. That "partially worked", e.g. some things like the Yast upgrade that follows the installation failed also, the kernel patch failed(!). I suspect the original system configurations from earlier crash was screwing up the installation/update. At that point I decided I'd better save everything.

Possibly some of the kmail stuff got zapped.

deh6 03-08-2008 10:25 PM

Just to close this thread--

I did find the email in the system save. It was under my nose, so to speak in:

Kmail on another Suse 10.2 machine as well as Suse 10.3 have the mail under

Consequently, 'find -name mail' would not turn up anything.

It's all back up and working.

All times are GMT -5. The time now is 10:11 PM.