LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-20-2004, 08:11 AM   #1
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Rep: Reputation: 30
how does someone configure sound?


I have a Realtek ALC202 Codec Chip.
A driver may be downloaded here: http://www.realtek.com.tw/downloads/...&Software=True

I don't know where to begin configuring this.

Do I download it from the place where all of the mods are stored (/lib/modules/), then add it to the list of modules that the system loads (/etc/modules.autoload.d/)?

Thanks to anyone who would give me advice/
 
Old 10-20-2004, 03:49 PM   #2
alar
Member
 
Registered: Sep 2003
Location: Canada
Distribution: Fedora 30
Posts: 341

Rep: Reputation: 37
The command sndconfig should be all you need.
 
Old 10-20-2004, 10:30 PM   #3
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
I am not using redhat and I do not have sndconfig in my /usr/sbin directory. Could you give me an alternative method.
 
Old 10-20-2004, 10:39 PM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
yea you download that driver -- make sure you have the source code for your current running kernel installed. then just follow the instructions that come with the driver -- should be a file called INSTALL
or something with insructions
 
Old 10-22-2004, 12:33 AM   #5
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
I don't know how to configure this. I don't understand any of the steps in the readme.txt:


...
Step 2. Turn on sound support (soundcore module, default turn on)

Step 3. Complied source code
a. ./configure
b. make
c. make install
d. ./snddevices

Step 4. Edit your /etc/modules.conf or conf.modules depending on the distribution
(Please refer to the attached modules.conf)

Step 5. reboot your machine


The module.conf file they attached looks like:


alias parport_lowlevel parport_pc
alias usb-controller usb-uhci
#alias sound-slot-0 via82cxxx_audio //remark this line, this is default audio driver

#====== added those lines =============
alias char-major-116 snd
options snd major=116 cards_limit=1
#--- Intel 8x0 and SiS 7012 ----------
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0 id="ICH"
#--- Via8233 Via686a -------------------------------
#alias snd-card-0 snd-via82xx
#options snd-via82xx index=0 id="VIA"
//=================================
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
#=================================
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :


I would appreciate help understanding this. thanks
 
Old 10-22-2004, 01:19 AM   #6
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
hi
try this

skip step 2. that's turned on in your kernel already

do step 3 from the command line.
move into the driver folder (cd ./driverfolder) whatever it's called then
./configure
then
make
then become root (su)
then
make install
now still as root run the device script
./snddevices

if any of this doesn't work post back with the error output and we can tell you what to do.

step 4

either add or make sure these lines are in modules.conf
alias char-major-116 snd
options snd major=116 cards_limit=1
options snd-intel8x0 index=0 id="ICH"
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
# and at the bottom of the file
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :


if you get this far and reboot and sound still is not working just post back
sound for linux is tedious but doable so don't give up
 
Old 10-22-2004, 02:43 AM   #7
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
ok, I'll follow your directions and post back
 
Old 10-22-2004, 03:02 AM   #8
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
OK

thanks for helping me,..but...

I followed all of the steps and I don't have my sound working.

after the fourth step in number 2, it gave me a message that said

mixer channels for the ALSA driver are muted by default!!!
You would use the same ALSA or OSS mixer to set the appropriate volume
 
Old 10-23-2004, 12:06 AM   #9
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
OH, I should also mention this

lsmod doesn't show anything that looks like ALSA

ls /etc/modules.d only shows "aliases i386 nvidia"
 
Old 10-23-2004, 12:13 AM   #10
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
you are getting there
yes once alsa is loaded any mixer should give you access
but some of them are incomplete or don't work so great
best to learn to use the command amixer

first try the command as root
modprobe snd-intel8x0

if it returns without complaining that's a good thing or tell us error mesages
 
Old 10-23-2004, 02:21 AM   #11
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
it returns without complaining

modprobe snd-intel8x0

the commands amix and aumix don't exist in my command line

should I download and use some other program?
 
Old 10-23-2004, 03:02 PM   #12
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
OK, I figured some stuff out. I downloaded the alsa-utils driver from the alsa webpage. I've tried installing the recommended version and a more updated version and both times when I run ./configure, it eventually responds
error: Sufficiently new version of libasound not found

I'm trying to fix this problem, I'll report back if I do find a solution
 
Old 10-23-2004, 03:20 PM   #13
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
OK, I downloaded and installed a matching version of lib from the alsa page and now it also let me install the utils driver,...I think I'm on my way to having sounds....
 
Old 10-23-2004, 05:16 PM   #14
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
OK, after lots of time and work, I do not have sound

the correct lines are in /etc/modules.conf
I'v loaded the alsa library and alsa mixer

everything seems to be in order, there is only one problem that I can mention.

Each time I boot my computer up, the alsamixer levels are at 0 again.
I set them to 100 then issue the command "alsactl store", but it doesn't REALLY store it, because when I boot back up again, levels are at 0

could you help me to get my sound working? I'll provide any information you need.
 
Old 10-23-2004, 05:40 PM   #15
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
My sound works now.

one problem still alsactl store doesn't allow me to reboot with the sound settings that I create

Each time I reboot, I have to re set and un mute my sound in amixer.

Does anyone have a soultion?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure sound in FC 3 DanielTan Linux - Newbie 22 06-08-2005 07:55 PM
help configure my sound Squall__99 Mandriva 1 05-26-2005 08:19 PM
how do I configure sound in 9.1? walterbyrd Slackware - Installation 2 04-11-2004 07:05 PM
Can't configure my sound card! fahdaziz Linux - Hardware 2 03-18-2004 09:17 PM
How to configure sound in an old Compaq Mega Man X Slackware 8 08-26-2003 08:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration