LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-06-2009, 05:32 AM   #1
nvpnvp
LQ Newbie
 
Registered: Jan 2009
Location: Germany
Distribution: debian
Posts: 2

Rep: Reputation: 0
How does rsync's --fake-super option work?


Hi,

First some background information: I am trying to back up machine2:/homes/mydir to machine3:/backup/mydir using rsync. I am running the rsync command on machine1, while machine2:/homes/mydir and machine3:/backup/mydir are respectively mounted (using cifs) on machine1 as /homes.machine2/mydir and /homes.machine3/mydir . Machine1 is my personal work computer (debian linux), machine2 is the server (debian linux), and machine3 is running Windows 2003. I don't have permission to login to machine2, and I only have space on machine3 as a favour, so I can't ask the Administrator of machine3 to install any programs. It is a bare bones windows installation. Hence my inefficient use of rsync to perform a local copy between mounted directories. So far it is working, except that the permissions of the files on /homes.machine3/mydir are changed, because machine3 is really a windows computer. As an example, a file on /homes.machine2/mydir which has the permissions
-rwx------
has the permissions
-rwxrwSrwx
on /homes.machine3/mydir .

I thought that, when I invoked the --fake-super option, rsync would somehow store the correct permissions so that, when I restore my data from machine3, the permissions would be like they were on machine2. Is that what --fake-super is intended to do? How is rsync exactly storing these permissions when --fake-super is invoked? Are they being stored in a separate file?

When I tried the --fake-super option it seemed to have no effect. Repeated invocations of rsync kept trying to update the permissions of the same files on /homes.machine3/mydir . Is this because machine3 is a windows computer? Does that prevent rsync from "saving/restoring the privileged attributes via special extended attributes that are attached to each file", (according to the rsync man page).

Or am I using the wrong options with rsync? I am using the following command:
rsync -avi --fake-super --copy-unsafe-links --exclude-from=my_exclude_file /homes.machine2/mydir/ /homes.machine3/mydir

I tried inserting the --xattrs option into the above command, but that didn't help. I am using a recent version of rsync, and my kernel is 2.6.26-1-686 . According to my google searches, no-one else reports that --fake-super has no effect. I guess that means I am doing something fundamentally wrong.

Any answers to my questions regarding --fake-super will be greatly appreciated.

Last edited by nvpnvp; 01-06-2009 at 07:14 AM.
 
Old 01-06-2009, 06:12 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Arch + Xfce
Posts: 6,852

Rep: Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037
I'm no expert in such things, and I can't say anything about rsync, so I could be completely wrong, but I'm thinking the more likely reason is the fact that Windows partitions, NTFS and FAT, can't handle *nix-style permissions. The file systems just don't support them. When you mount them or connect to them through a network, the ownership and permissions you see are actually simulated through mount options.

So it's my guess it that you're simply putting the files on a partition that can't handle permissions. If so, then there are probably ways to work around it, but you'll need someone more experienced than me to tell you how. You may have to wrap up the files in a tar package or something, for example.
 
Old 01-06-2009, 06:44 AM   #3
nvpnvp
LQ Newbie
 
Registered: Jan 2009
Location: Germany
Distribution: debian
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by David the H. View Post

So it's my guess it that you're simply putting the files on a partition that can't handle permissions. If so, then there are probably ways to work around it, but you'll need someone more experienced than me to tell you how. You may have to wrap up the files in a tar package or something, for example.
Thanks for your fast response David. The rsync man page says that the --fake-super option is "a good way to backup data without using a super-user, and to store ACLs from incompatible systems." I was hoping that windows 2003 was included in this set of incompatible systems. Although perhaps this quote from the man page means that rsync can only store ACLs from incompatible systems, but not to incompatible systems?
 
  


Reply

Tags
rsync


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
python how to work with fake csv donnied Programming 2 09-29-2008 06:05 AM
Solving RSYNC's rather poor directory-exclude ability? hockeyrink Linux - Software 4 08-18-2006 03:11 PM
can't understand rsync's behavior at all baronsam Linux - Software 5 08-15-2006 01:46 PM
Atheros Super G don't work spoody_goon Linux - Laptop and Netbook 5 09-26-2004 07:05 PM
File manager ( super user) doesn't work slacard Slackware 0 10-01-2003 11:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration