LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-27-2008, 10:00 PM   #1
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Rep: Reputation: 38
How do you stop vmware server at boot?


Hi
I have the vmware server running on my box all the time.
I was wondering how to keep vmware server from startup at boot.
I would prefer to run vmware only when I access my ntfs partition and not all the time.

Thanks
 
Old 04-28-2008, 01:25 PM   #2
Rustylinux
Member
 
Registered: Mar 2006
Posts: 177

Rep: Reputation: 30
Quote:
Originally Posted by okos View Post
Hi
I have the vmware server running on my box all the time.
I was wondering how to keep vmware server from startup at boot.
I would prefer to run vmware only when I access my ntfs partition and not all the time.

Thanks
I forget where the option is but it is inside VmwareServer. There is a little check box in its options stating weather or not you want it to auto start when you boot. Just uncheck that. If that doesn't work you can look in your start up programs under i think Systems>Software or something a long thouse lines. There is a few places to look for auto-starting stuff but I forget them all off the top of my head. I will link you a post from one of my other conversations with all the auto-start places for you later when I get home.
 
Old 04-28-2008, 11:25 PM   #3
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Original Poster
Rep: Reputation: 38
Thanks for the response.
I think the /etc/rc.d/rc.M stops many of the startup daemons but not vmware on my system.
There is also /etc/inetd.conf which only open tcp 902 for the vmware server. I added # but the server still starts only the port is closed.


I am not sure what you mean about system>software.
Ill start up vmware and check the settings.

Thanks
 
Old 04-29-2008, 09:26 AM   #4
Rustylinux
Member
 
Registered: Mar 2006
Posts: 177

Rep: Reputation: 30
Quote:
Originally Posted by okos View Post
Thanks for the response.
I think the /etc/rc.d/rc.M stops many of the startup daemons but not vmware on my system.
There is also /etc/inetd.conf which only open tcp 902 for the vmware server. I added # but the server still starts only the port is closed.


I am not sure what you mean about system>software.
Ill start up vmware and check the settings.

Thanks
Hey,

Sorry I didn't get back to you yesterday some things came up, anyhow here is the previous post I had about all the places where things can hide to auto start:

http://www.linuxquestions.org/questi...arting-620000/

Also i'll see if i can dig up exactly where that start on boot up option is on vmware server.
 
Old 04-29-2008, 10:13 AM   #5
Rustylinux
Member
 
Registered: Mar 2006
Posts: 177

Rep: Reputation: 30
Just some other info i dug up:

Well, first of all it depends on what command you want to run and when.

/etc/rc.d has a number of scripts that are started when the server restarts. What is started and in what order is determined by init, depending on your runlevel. In /etc/inittab look for "initdefault", and look what number is there in field 2. Let's say default runlevel is 5, then all scripts that are in /etc/rc5.d, that begin with S<number> will be started when system starts in the order of increasing number after S and all the scripts that start with K<number> will be ran whien system shuts down to kill the processes.

So, if you need to start a daemon or something, I'd recommend creating an init script in /etc/init.d and then enable it by doing chkconfig --level <runlevels to start on> on, e.g. chkconfig --level 345 on.

As people suggest, /etc/rc.d/rc.local is another solution if you need to run anything small. Note, however, that rc.local is run last and that your command needs to finish. I.e. if it will stay in foreground, you'll never see your console until you finish the program. So if it's a foreground application, put a & sign in the end of the commandline to force it into the background during boot.
 
Old 04-30-2008, 05:59 PM   #6
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Original Poster
Rep: Reputation: 38
Rusty,
Thank you for the lesson!

It prompted me to look up on the subject of rc.d and init.d.

I found this article helpful:
http://www.linux.com/articles/114107

I looked at all of my run level files rc1 - rc5 and found that all of them have symlinks to vmware. I have slackware and I believe multi-user is at run level 3 or 4. Ill have to check again. I will comment out vmware at all run levels and will let yo know.

Furthermore, I have kde and find startup services or administrator in the kde programs list.

Thanks Rusty from a noob
 
Old 04-30-2008, 06:30 PM   #7
Rustylinux
Member
 
Registered: Mar 2006
Posts: 177

Rep: Reputation: 30
Quote:
Originally Posted by okos View Post
Rusty,
Thank you for the lesson!

It prompted me to look up on the subject of rc.d and init.d.

I found this article helpful:
http://www.linux.com/articles/114107

I looked at all of my run level files rc1 - rc5 and found that all of them have symlinks to vmware. I have slackware and I believe multi-user is at run level 3 or 4. Ill have to check again. I will comment out vmware at all run levels and will let yo know.

Furthermore, I have kde and find startup services or administrator in the kde programs list.

Thanks Rusty from a noob
No problem. I hope it helps and you find the option to turn it off Let me know how it all turns out.
 
Old 05-01-2008, 10:46 PM   #8
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Original Poster
Rep: Reputation: 38
Thanks for the help rusty,

See this link on the resolution.
http://www.linuxquestions.org/questi...t-boot-639012/

You have to chmod -x /etc/rc.d/init.d/vmware

For some reason slackware has init.d in both /etc and /etc/rc.d.

I had previously chmod -x /etc/init.d/vmware but vmware still booted.

Sincerely
okos

UPDATE-----------------
Since I am rather new to linux it seem that slackware does not naturally have /etc/init.d.

Last edited by okos; 05-01-2008 at 11:40 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vmware server install error, The VMware VmPerl Scripting API was not installed. fakie_flip Linux - Software 4 12-28-2008 04:49 AM
dual boot win XP and fedora + VMware virtual server with the same file system titel Linux - General 4 06-09-2007 08:32 PM
How to stop usblp module grabbing printer before VMware danny678010 Linux - Hardware 1 05-30-2007 09:47 AM
LXer: VMware Introduces Free VMware Server LXer Syndicated Linux News 0 02-07-2006 08:46 AM
LXer: VMware cuts VMware Server price to zero LXer Syndicated Linux News 0 02-04-2006 03:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration