-   Linux - Software (
-   -   How do I run jack well as normal user instead of root? NO /etc/security/limits.conf! (

el_b 09-20-2009 10:09 PM

How do I run jack well as normal user instead of root? NO /etc/security/limits.conf!
UPDATE: I can run JACK with no problems at all AS ROOT, what I read was about compiling a SECURITY_CAPABILITIES module which isn't available in After adding the CONFIG_SECURITY, nothing changed. there's no /etc/security/ directory. What do I need to do to run the damn Jack as a normal user? or how could I run it as "root" from rc.d AND make it work well with all of my software: firefox, XMMS, VLC, etc?

JACK works fine without a single XRUN as long as I don't use fluidsynth. I have rosegarden running with no problems nor warnings at startup, Realtime kernel
When I use qsynth, jack start flooding with XRUNS. In about 5 minutes, I can get about 30-50 XRUNS.
Is it because fluidsynth uses software, not hardware, for generating sound?
How can I stop it from making so many XRUNS? Also, it makes a buzzing sound when the volume is high enough, which doesn't happen with normal music. It doesn't even have to make XRUNS.
Thanks in advance..

Shadow_7 09-21-2009 02:29 AM

The standard M$ answer would be to get a faster CPU, more RAM, and other stuff. But you probably know that already.

My guess would be that fluidsynth is probably creating content that needs a rate conversion to play back on the soundcard. Perhaps starting jackd with a compatible rate 44100 instead of 48000 (or whatever is actually being used) could help. Is jackd being run with realtime priority? -R ?

el_b 09-21-2009 11:00 PM

1 Attachment(s)
It is being run with realtime property, I'm also using QJackCTL.
I've tried changing the sample rate in qjackctl but it doesn't seem to change, I changed it in qjackctl and qsynth to 44100
but qjackctl still said it was 48000 in the display, and it sounded totally out of tune...
I'll try using the CLI...

EDIT: I ran QJackCTL as root and got no problems. I guess it has something to do with permissions.. Anyone know how to make it work as a normal user?

el_b 09-22-2009 11:30 PM

It seems it has something to do with /etc/security/limits.conf... I had disabled security options on my kernel so there was no /etc/security/ directory. There should be better documentation...

EDIT: i see no security_capabilities option with all the deprecated, etc options in general and kernel hacking. There is NO /etc/security/limits.conf file.

el_b 09-24-2009 07:02 PM


All times are GMT -5. The time now is 10:09 PM.