LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-18-2009, 12:05 PM   #1
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Rep: Reputation: 0
How do i remove write-protection on my external hdd?


I have an external harddrive, that is read-only, how do i change that?
When i go to Volume Properties > Permissions and change Folder Access from "Access files" to "Create and delete files", i get this message:

> The permissions could not be changed.
> Couldn't change the permissions of "disk" because it is
> on a read-only disk.

Its an "Power EH-25SR" box, with a Toshiba MK6034GAX disk.

Any tips appreciated
 
Old 03-18-2009, 12:26 PM   #2
mr_magen
LQ Newbie
 
Registered: Mar 2009
Location: Europe
Distribution: Debian, Gentoo, Slackware
Posts: 19

Rep: Reputation: 2
well, first you need to know what type of partition is on the hd. if it is NTFS you'll probably have to follow some instruction (depending on our distro, some come with NTFS support out of the box, i don't know linpus). you should give a look to your /etc/fsatb to see if it all right there. i suggest you post your partition type, your /etc/fstab and perhaps the environment used. btw, have you tried mounting through the command line?
 
Old 03-18-2009, 01:21 PM   #3
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,820

Rep: Reputation: 229Reputation: 229Reputation: 229
You use chmod, assuming it is linux.

Open a terminal as root (su or sudo or some such) and use the command "chmod". You might type "man chmod" first. I assume you can enter a terminal and switch to root privileges in linpus, but if not you might try to find out how to do that first.

Here is an explanation of the matter at hand.

http://www.tuxfiles.org/linuxhelp/filepermissions.html

Here is the standard standing admonition to the forwarding of better behavior.

http://www.linuxquestions.org/linux/...Ask_a_Question

Last edited by thorkelljarl; 03-18-2009 at 01:23 PM.
 
Old 03-18-2009, 01:32 PM   #4
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Original Poster
Rep: Reputation: 0
It is NTFS.
No i have not tried mounting through the commandline. I dont know how to do that?
(im new to linux).

I can open my openoffice documents that is on this hdd, without problems. Does that mean my distro have NTFS support out of the box?

This is my /etc/fstab:

LABEL=linpus / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/sr0 /media/cdrom udf,iso9660 pamconsole,exec,noauto,managed 0 0

Not sure what you mean by environment used?

chmod gives this result:
[root@localhost media]# ls
cdrom disk
[root@localhost media]# chmod a=rwx /media/disk
chmod: changing permissions of `/media/disk': Read-only file system
[root@localhost media]#

Thanks

Last edited by Donati; 03-18-2009 at 02:18 PM. Reason: added chmod output
 
Old 03-18-2009, 02:29 PM   #5
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,820

Rep: Reputation: 229Reputation: 229Reputation: 229
This has been useful for many new to linux.

http://www.linux.org/lessons/beginner/toc.html
 
Old 03-18-2009, 04:05 PM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 21,115

Rep: Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120
Let's see the output from "mounts" (no quotes) issued from a terminal.
 
Old 03-18-2009, 04:31 PM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,622

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
Quote:
I can open my openoffice documents that is on this hdd, without problems. Does that mean my distro have NTFS support out of the box?
maybe may not it depends on WHAT Limpus installed
If it is the VERY old "ntfs" plugin then it is READ ONLY
But if it is the new " ntfs-3g " then it is read AND wright

to find out run this in the terminal ( should work as a normal user but you might need to be root to do it )
Code:
rpm -qa | grep ntfs
my output for fedora 9 is " ntfs-3g-2009.2.1-2.fc9.i386"

if it is ntfs-3g let us know and we can help you make a change to your /ect/fstab file .
 
Old 03-18-2009, 04:33 PM   #8
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Original Poster
Rep: Reputation: 0
[Donati@localhost ~]$ mount
/dev/sda3 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sdb1 on /media/disk type ntfs (rw,nosuid,nodev,uhelper=hal,umask=222)
[Donati@localhost ~]$

Does it look right to you?
 
Old 03-18-2009, 04:42 PM   #9
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 21,115

Rep: Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120Reputation: 4120
Oops - shoulda been "mount" as you obviously figured. Sorry about that ...

Probably the in-kernel NTFS support - in which case I'd be loathe to try updates anyway.
ntfs-3g would be the answer, but I don't know anything about Linpus.
 
Old 03-18-2009, 04:43 PM   #10
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Original Poster
Rep: Reputation: 0
[Donati@localhost ~]$ rpm -qa | grep ntfs
[Donati@localhost ~]$

Does'nt give any output?
 
Old 03-18-2009, 05:09 PM   #11
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,622

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
Quote:
/dev/sdb1 on /media/disk type ntfs (rw,nosuid,nodev,uhelper=hal,umask=222)
here is your problem .
edit your /ect/fstab file ( as root ) and remove " ,umask=222 " that part of the line ONLY ( no "" )

and if that line is not in there then there is a auto mount rule that will need changing .

Last edited by John VV; 03-18-2009 at 05:15 PM.
 
Old 03-18-2009, 05:37 PM   #12
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by John VV View Post
..edit your /ect/fstab file ( as root ) and remove " ,umask=222 " that part of the line ONLY ( no "" )

and if that line is not in there then there is a auto mount rule that will need changing .
It is not there, so i need to find out how to edit auto mount rules.
Any hints, what i could do? Im sorry, i dont even know wich program takes care of the auto mount service.

Last edited by Donati; 03-18-2009 at 05:41 PM. Reason: Spelling
 
Old 03-18-2009, 06:12 PM   #13
openSauce
Member
 
Registered: Oct 2007
Distribution: Fedora, openSUSE
Posts: 252

Rep: Reputation: 39
It's not automount, the problem is you don't have ntfs-3g installed. Does linpus have a package management system you can use to install it? Look for a menu item called add/remove software or something similar. If not, you can try following the instructions on the site above - looks like you'll need to compile from source.

Here is a post explaining how Linux handles permissions for NTFS filesystems, but it doesn't apply to you until your system has ntfs write support.
 
Old 03-18-2009, 07:03 PM   #14
Donati
LQ Newbie
 
Registered: Mar 2009
Location: Silkeborg, Denmark
Distribution: Linpus Linux
Posts: 18

Original Poster
Rep: Reputation: 0
Linpus have Synaptics Package Manager, but im still to figure out how to use it

I have downloaded ntfs-3g-2009.2.1.tgz, and installed it from terminal like so:
./configure
make
make install

I think it installed ok.. but "rpm -qa | grep ntfs" still does'nt give any output.
 
Old 03-18-2009, 07:44 PM   #15
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,622

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
when you do a source install the rpm data base will know nothing about it UNLESS you turn it into a rpm to install

also Did you uninstall the ntfs rpm FIRST having both installed at the same time is NOT a good idea, and would in all likely hood kill BOTH .

from the GUI package manager find the ntfs program and uncheck it
that will uninstall it
then go back to the ntfs-3g-2009.2.1 folder .Open a terminal in that folder ( or cd to it )
and run .BUT before you do ANY OF THIS read the two files called " README " and " INSTALL "
Code:
./configure --help
and in that out put look to see where it installs .
most will want to install in " /usr/local"
this you DO NOT want . You want it to install in /usr . To do that you add -- prefix=/usr to the configure
like this
Code:
cd /to /where/the/folder/is
./configure --prefix=/usr
( -- if no errors then do -- ) 
make
( -- if on errors then do -- )
su -  
( or if you have sudo set up use sudo )
make install
you must be root to run " make install "
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to remove write protection from pen drive in linux sanatkrtiwari86 Linux - Newbie 3 03-04-2009 12:48 PM
HDD write protection pingvina Linux - Software 17 02-11-2006 06:59 PM
write protection speed_viper Linux - Software 5 10-02-2004 12:10 AM
Write Protection mfo6463 Linux - Newbie 5 03-31-2004 03:59 PM
cannot write on external HDD trutnev Red Hat 2 03-20-2004 03:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration