LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-06-2005, 07:33 PM   #1
patkalolo
Member
 
Registered: Jul 2004
Location: Seattle
Distribution: Slackware 10.0
Posts: 38

Rep: Reputation: 15
Hopefully a STUPID sound question!?


I am using alsa-driver, alsa-lib, and alsa-utils 1.0.8. I thought I had sound set to work at boot with the following line in my /etc/rc.d/rc.local file:

Code:
#!/bin/sh
#
# /etc/rc.d/rc.local:  Local system initialization script.
#
# Put any local setup commands in here

#bring up alsa

alsactl restore

#commands to bring up my wpa-psk wlan0 connection
modprobe ndiswrapper
ifconfig wlan0 192.168.0.111
route add -net default gw 192.168.0.1
wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf -B
Unfortunately, I hear sound during the Slackware splash screen up until the "Restoring Session" message is displayed and the it all goes silent. It isn't until I issue the command "alsactl restore" in a terminal that my sound works again? Why would my KDE session decide to automatically reverse something I have in a startup script?
 
Old 05-06-2005, 07:37 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
arts
http://freshmeat.net/projects/arts/?branch_id=32187
 
Old 05-06-2005, 07:38 PM   #3
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
kde loads a daemon called ARtS. It's a software mixer to enable several programs to use the sound card at once. It could be that its default settings turn audio down or mute it. Have a look for a kmixer app or something in KDE that might show you the sound levels. Failing that, there is an option to disable arts somewhere in KDE. Sorry I can't be more specific, but I don't use KDE.
 
Old 05-18-2005, 10:45 PM   #4
patkalolo
Member
 
Registered: Jul 2004
Location: Seattle
Distribution: Slackware 10.0
Posts: 38

Original Poster
Rep: Reputation: 15
Well after starting a new x session with kde I find that my "PCM" is muted in KMIX. I am attempting to store the revised setting via "alsactl store" and I will see what happens.
 
Old 05-18-2005, 10:49 PM   #5
patkalolo
Member
 
Registered: Jul 2004
Location: Seattle
Distribution: Slackware 10.0
Posts: 38

Original Poster
Rep: Reputation: 15
It's amazing what a little "time-out" will do for your problem solving skills. Need I say that the simplest problems are usually the hardest to solve?

SUCCESS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stupid, stupid question; I lost Klaptop. :( Surfrider Slackware 2 08-31-2005 10:12 PM
Stupid Dumb Stupid Question... drigz Linux - Software 3 09-23-2004 04:09 PM
This might sound like a stupid question to the experienced. crumb Slackware 2 08-16-2003 05:57 PM
Yet another stupid sound question bigjohn Linux - Newbie 1 10-03-2002 08:28 PM
Hopefully a stupid Newbie Question - Sound/Permissions airsylph Linux - Newbie 2 01-26-2002 03:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration