LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Help with xvidtune (https://www.linuxquestions.org/questions/linux-software-2/help-with-xvidtune-135587/)

BajaNick 01-16-2004 08:01 PM

Help with xvidtune
 
Does anyone know why when i try to use xvidtune it doesnt hold my settings? I tried using it several times but when i reboot or restart x the screen goes back to the same position it was at.:confused:

BajaNick 01-16-2004 10:33 PM

Anyone???

speck 01-16-2004 11:57 PM

You're correct, it won't remember your settings after you reboot (or quit X.) First, be sure to start xvidtune from an xterm (or rxvt, etc) so you can see the program output. After you've made all the changes you want to make in xvidtune, click the "show" button and the modeline settings will be displayed in your xterm. It should look something like this:

Code:

Vendor: Unknown, Model: Unknown
Num hsync: 1, Num vsync: 1
hsync range 0:  27.00 -  92.00
vsync range 0:  50.00 - 160.00
"1152x864"    121.50  1152 1216 1344 1568    864  865  868  911 +hsync -vsync

You now need to edit the /etc/X11/XF86Config-4 file and put that Modeline into the "Monitor" section. Example:

Code:

Section "Monitor"
    Identifier "Iiyama MT-9017E/T, VisionMasterPro"
    VendorName "Unknown"
    ModelName  "Unknown"
    HorizSync 27-92
    VertRefresh 50-160
          Modeline "1152x864"    121.50  1152 1216 1344 1568    864  865  868  911 +hsync -vsync
    Option "dpms"
EndSection

Now when you reboot (or just restart X) it will use the settings that you wanted in xvidtune.

Speck

BajaNick 01-17-2004 02:39 PM

But heres my problem. When in X the screen is OK, but when i goto a console by hitting Ctrl-alt-any fkey the console is off the screen about half an inch. I cannot start xvidtune in a console unless im in X and i need to see what i need to set in XFree, also I dont have an XF86Config-4 just XF86Config. Its the same thing right? Thanks

speck 01-17-2004 03:19 PM

An xterm, rxvt, gnome-terminal, etc will only run under X, not in the console. Also, xvidtune is only for your X session, not the console. Yes, the XF86Config file is the same as XF86Config-4, but I don't know why you only have a XF86Config if you're running Slack 9.1 (I don't think I renamed my file when I install Slack.)

Most monitors have multiple saved settings, depending on resolution. Have you tried adjusting the settings on your monitor when you are in the console? If the console monitor adjustments move your X screen around (when you switch back into X), then your monitor isn't "smart" enough handle multiple resolution settings. If that's the case, I would suggest making all the left/right/up/down wider/thinner/taller/shorter adjustments in the console first, switch back to X and then run xvidtune with the info I posted earlier.

Speck

BajaNick 01-17-2004 07:40 PM

Ok, So wherever the real console is at that is the actual screen position? and all ill need to do is move X to sync it with the console? If so, That is the Original problem I was having using my KVM switch because X and WinXP were not in sync so i moved XP over and then that fixed the problem but left the console where it was at. My monitor is a VS pf790 and is a really good one, why would it not support multiple resolution settings?

I just tried it and it Does not work. Is there supposed to be multiple ModeLine Lines?? cuz i have like 5 or 6 in my XF86Config file.

BajaNick 01-17-2004 08:58 PM

Whoo hoo! Got it to work, thanks for the info. After screwing around with VIM for 30 minutes i finally decided to login as root and change XF86Config with Kwrite, LOL. :D

speck 01-17-2004 11:27 PM

Hey, patience and persistence are good qualities to have ;)

Speck


All times are GMT -5. The time now is 03:01 AM.