LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-15-2008, 10:34 AM   #1
mrlinux2000
Member
 
Registered: Feb 2008
Posts: 144

Rep: Reputation: 15
help with Squid


hi !

anyone can show me how to configure squid and squid guard ,

i did a try but it didnt work , i want if some one can give me an address or show me how to do that STEP by STEP from the beginning !!!
 
Old 02-15-2008, 11:04 AM   #2
weisso5
Member
 
Registered: Oct 2007
Location: New York City
Distribution: Gentoo, FC
Posts: 133

Rep: Reputation: 16
What distro are you using and what is your network setup?


Need more information to answer a general question like that.

-weisso
 
Old 02-15-2008, 10:07 PM   #3
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
You could get started by Googling for Squid HOWTOs and SquidGuard HOWTOs.
 
Old 02-16-2008, 05:57 AM   #4
mrlinux2000
Member
 
Registered: Feb 2008
Posts: 144

Original Poster
Rep: Reputation: 15
am using fedora core 3 and squid package installed within the fedora installation
 
Old 02-16-2008, 06:40 AM   #5
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 4,070

Rep: Reputation: 897Reputation: 897Reputation: 897Reputation: 897Reputation: 897Reputation: 897Reputation: 897
...this isn't the answer that you want, but you can do it perfectly adequately by reading squid.conf, understanding it and setting the settings appropriately.

The trouble is that its a bit long.
 
Old 02-16-2008, 07:20 AM   #6
mrlinux2000
Member
 
Registered: Feb 2008
Posts: 144

Original Poster
Rep: Reputation: 15
i did that , but when i restart squid it doesnt work....
when i block site ex: http_access deny yahoo.com and rstart squid , nothing change i still can access it

thank you salasi
 
Old 02-16-2008, 07:29 AM   #7
mrlinux2000
Member
 
Registered: Feb 2008
Posts: 144

Original Poster
Rep: Reputation: 15
how to direct outgoing HTTP traffic via Squid ???
 
Old 02-16-2008, 12:01 PM   #8
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
Quote:
Originally Posted by mrlinux2000 View Post
am using fedora core 3 and squid package installed within the fedora installation
Your distro doesn't really make any difference in this case.

Quote:
i did that , but when i restart squid it doesnt work....
when i block site ex: http_access deny yahoo.com and rstart squid , nothing change i still can access it
You should post your squid.conf file if you want us to have a look - use a command like:
Code:
cat /etc/squid/squid.conf | grep -v ^# | grep -v ^$
This way we won't get spammed with comments and spaces.

Quote:
how to direct outgoing HTTP traffic via Squid ???
If you click the first link I posted, the first search result explains how to do this.

Last edited by win32sux; 02-16-2008 at 12:03 PM.
 
Old 02-17-2008, 03:03 AM   #9
mrlinux2000
Member
 
Registered: Feb 2008
Posts: 144

Original Poster
Rep: Reputation: 15
http_port 3128 8080
hierarchy_stoplist cgi-bin ?
acl QUERY urlpath_regex cgi-bin \?
no_cache deny QUERY
pid_filename /var/run/squid.pid
auth_param basic children 5
auth_param basic realm Squid proxy-caching web server
auth_param basic credentialsttl 2 hours
auth_param basic casesensitive off
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern . 0 20% 4320
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SL_ports port 443 563
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT
http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
acl our_networks src 192.168.1.1
acl bad dstdomain .yahoo.com
http_access deny bad
http_access deny our_networks
http_access allow localhost
icp_access allow all
httpd_accel_port 80
coredump_dir /var/spool/squid
 
Old 02-17-2008, 03:29 AM   #10
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
Your yahoo.com stuff looks fine to me. Are you positive that the clients are connecting through Squid? I suspect they might be getting routed instead.
 
Old 02-17-2008, 04:42 AM   #11
mrlinux2000
Member
 
Registered: Feb 2008
Posts: 144

Original Poster
Rep: Reputation: 15
yes they're connecting via a local area network and my server linux route them ,
 
Old 02-17-2008, 04:47 AM   #12
gzunk
Member
 
Registered: Sep 2006
Posts: 89

Rep: Reputation: 20
Quote:
Originally Posted by mrlinux2000 View Post
yes they're connecting via a local area network and my server linux route them ,
Yes, but are the proxy settings in the browser on the client set to use Squid? Try tailing the squid.log file while at the same time making a request from one of the client machines. You should see something appear in the squid log file.
 
Old 02-17-2008, 09:15 AM   #13
mrlinux2000
Member
 
Registered: Feb 2008
Posts: 144

Original Poster
Rep: Reputation: 15
they are not , how to do that ?
thank you
 
Old 02-17-2008, 03:18 PM   #14
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
In Mozilla Firefox you'd go to:

Edit > Preferences > Advanced > Network > Settings > Manual proxy configuration
 
Old 02-18-2008, 06:27 AM   #15
mrlinux2000
Member
 
Registered: Feb 2008
Posts: 144

Original Poster
Rep: Reputation: 15
and for explorer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SQUID for blocking yahoo and msn [inc squid.conf] chrisfirestar Linux - Security 10 03-03-2008 08:33 AM
Squid: special configuration for remote Squid server hamish Linux - Software 0 12-06-2005 03:58 PM
squid message customization, hiding squid versioin rajnishmishra Linux - Networking 0 11-27-2004 03:55 AM
squid conf: squid failed when I type insert redirect_program /usr/bin/squidguard Niceman2005 Linux - Software 1 11-24-2004 02:29 PM
Squid load testing software / Squid optimisation? gundelgauk Linux - Networking 2 08-31-2004 07:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration