LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-25-2003, 06:46 PM   #1
DermicSavage
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
help with install


i have just this weekend started messing with red hat(9), and i am trying to install mplayer, but when i try to double click the rpm(using gnome) it will bring up the preparing to install dialoge, then goes away, and then nothing else happens

i have tried it on all these rpms:
mplayer-common-1.0pre2-1.i386.rpm
mplayer-gui-1.0pre2-1.i386.rpm
mplayer-skin-default-1.0-2.noarch.rpm

i get an error that i am missing mplayer-gui dependancy for when trying to install the skin, but otherwise i get the same problem with the other two

i went into the terminal to try the command line

$ rpm -i mplayer-common-1.0pre2-1.i386.rpm
warning: mplayer-common-1.0pre2-1.i386.rpm: V3 DSA signature: NOKEY, key ID 28a26067
error: Failed dependencies:
mplayer = 1.0pre2 is needed by mplayer-common-1.0pre2-1

$ rpm -i mplayer-gui-1.0pre2-1.i386.rpm
warning: mplayer-gui-1.0pre2-1.i386.rpm: V3 DSA signature: NOKEY, key ID 28a26067
error: Failed dependencies:
mplayer-skin is needed by mplayer-gui-1.0pre2-1
mplayer-common = 1.0pre2 is needed by mplayer-gui-1.0pre2-1

so lastly, i tried to load all of them and got

$ rpm -i mplayer-common-1.0pre2-1.i386.rpm
mplayer-gui-1.0pre2-1.i386.rpm mplayer-skin-default-1.0-2.noarch.rpm
warning: mplayer-common-1.0pre2-1.i386.rpm: V3 DSA signature: NOKEY, key ID 28a26067
warning: only V3 signatures can be verified, skipping V4 signature
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm


would anyone be able to help me here?

could it be i am missing other dependancies, the site gives a list that i would need, but i have not been able to find where my dependancies are listed

much thx for the help
 
Old 10-25-2003, 09:09 PM   #2
serz
Member
 
Registered: Apr 2003
Location: Buenos Aires, Argentina
Distribution: Slackware, Gentoo
Posts: 397

Rep: Reputation: 30
You have to be root to do that. Use "su -" to become root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fc3 install doesnt install grub properly onto sata drive sabo Linux - Newbie 4 02-03-2007 04:04 PM
make install does not install daemons (clamd snortd). Is this a feature of tarball? Emmanuel_uk Linux - Newbie 3 11-15-2005 01:29 AM
Error: Unable to boot /install/2.6/linux when starting Etch Install BuckRogers01 Debian 4 08-06-2005 06:40 PM
How do I re-install an operatingsystem? Corrupted install. Yast wont load. URGENT.thx CrewXp SUSE / openSUSE 5 05-09-2005 12:07 AM
Ok, dumb question. If I install a Mandrake kernel RPM, where does it install to? Kramer Linux - General 6 01-13-2004 09:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration