-   Linux - Software (
-   -   Help with Eroaster and cdda2wav (

PiMoGo 10-28-2002 09:56 PM

Help with Eroaster and cdda2wav
I ran a test install of eroaster 2.0.12 and i was told i had to install 3 other packages including cdda2wav. I installed all 3 and re-ran the install but cdda2wav was still listed. I ran a search and sure enough i found cdda2wav 1.11 in /usr/bin/cdda2wav and in several other locations. When i tried running cdda2wav from the terminal by typing 'cdda2wav' in the command line i got the following error:

[pimogo@diebenkorn Downloads]$ cdda2wav
cdda2wav: Invalid argument. Invalid bus or target specifier in 'yourSCSI_Bus,yourSCSI_ID,yourSCSI_LUN'. Cannot open SCSI driver.
open(yourSCSI_Bus,yourSCSI_ID,yourSCSI_LUN) in file interface.c, line 524. Use the script scan_scsi.linux to find out more.
Probably you did not define your SCSI device.
You can scan the SCSI bus(es) with 'cdrecord -scanbus'.
Set the CDDA_DEVICE environment variable or use the -D option.
You can also define the default device in the Makefile.

I checked my scsi-bus by running cdrecord -scanbus and got what i knew i would get.....

[pimogo@diebenkorn Downloads]$ cdrecord -scanbus
Cdrecord 1.11a32 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.6'
0,0,0 0) *
0,1,0 1) *
0,2,0 2) *
0,3,0 3) 'HP ' 'CD-Writer+ 9100 ' '1.0c' Removable CD-ROM
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

It lists my cd-burner but not my cd-rom because i haven't added scsi-emulation to it. What must i do to get cdda2wav to work in conjunction with eroaster so i can install it?

I appreciate any help. Thanks in advance

acid_kewpie 10-29-2002 03:21 AM

well that's not an error is it? you've just not given cdda2wav a parameter that it has to have, it looks like it's working fine

are you installing eroaster from an rpm? i've found that cdda2wav often comes in two different packages, plain "cdda2wav" or "cdrecord-cdda2wav" eroaster wants (i think) the first package name, and doesn't check for the second, which mandrake has. if that's the only dependecny problem you are having, try forcing the installation regardless (rpm -ivh --nodeps eroaster.rpm)

PiMoGo 10-29-2002 11:32 AM

ok i'll try that once i get home. I am installing it from the rpm. i don't remember which version of cdda2wav i installed but i thought it was the first, but i'll check into that. so that should be it you think?

what does this mean....

Set the CDDA_DEVICE environment variable or use the -D option.
You can also define the default device in the Makefile.

Thanks for the help acid_kewpie.

All times are GMT -5. The time now is 08:38 AM.