LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-20-2004, 07:38 AM   #1
ninja
LQ Newbie
 
Registered: Apr 2003
Distribution: Fedora Core 3
Posts: 15

Rep: Reputation: 0
Help me installing libglib please


Hello,

I am trying to install xmms on my fedora core 3 box. unfortunately, the ./configure tells me that I don't have Glib library installed. Also, the "rpm -q libglib" command tells me that the Glib has not been installed.

But I actually located these library files in the /usr/lib:

lrwxrwxrwx 1 root root 21 Nov 17 20:28 libglib-1.2.so.0 -> libglib-1.2.so.0.0.10
-rwxr-xr-x 1 root root 144284 Aug 9 09:34 libglib-1.2.so.0.0.10
-rw-r--r-- 1 root root 656320 Oct 13 14:36 libglib-2.0.a
lrwxrwxrwx 1 root root 22 Nov 17 20:54 libglib-2.0.so -> libglib-2.0.so.0.400.7
lrwxrwxrwx 1 root root 22 Nov 17 20:26 libglib-2.0.so.0 -> libglib-2.0.so.0.400.7
-rwxr-xr-x 1 root root 505200 Oct 13 14:36 libglib-2.0.so.0.400.7

Are these Glib library files ot they are just placeholders for Glib?

Thanks
 
Old 11-20-2004, 07:42 AM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Perhaps you need to install the development libraries? It may be called libglib-1.2-dev.rpm or somesuch
 
Old 11-20-2004, 07:43 AM   #3
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 62
Those would be the Glib Libraries. Try:
Code:
rpm -qu | grep "glib"
and see if that finds it.

If it does, try downloading and installing an rpm for xmms.

Alternatively, set up "apt4rpm" (Google for it, I cant rembember its website ) Then you can just run "aptget install xmms" and it will sort out all the dependancy issues.

I hope this helps
--Ian
 
Old 11-20-2004, 09:22 AM   #4
ninja
LQ Newbie
 
Registered: Apr 2003
Distribution: Fedora Core 3
Posts: 15

Original Poster
Rep: Reputation: 0
Hi Thanks for your idea.

I just downloaded "apt4rpm-0.69.0-0.noarch.rpm" and trying to install it. However, the following error message occurs. I totally don't know what is an apt-server??

[root@ninja ~]# rpm - i apt4rpm-0.69.0-0.noarch.rpm
warning: apt4rpm-0.69.0-0.noarch.rpm: V3 DSA signature: NOKEY, key ID 8c9b4b0d
error: Failed dependencies:
apt-server is needed by apt4rpm-0.69.0-0.noarch

I am a linux newbie and looking forward to studying more here.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK+-2.6.2 compile error: libtool looking in wrong place for libglib-2.0.la Locura Linux - Software 5 02-17-2005 03:51 PM
Installing Mono-got stuck while installing gtk-sharp chutsu Linux - Software 11 01-18-2005 08:25 PM
LibGlib Libraries This SUCKS! =) Kane635 Linux - Software 0 11-24-2004 02:18 PM
grep: /usr/lib/libglib-2.0.la: No such file or directory FirstTimeUser Linux - Software 9 10-15-2003 09:53 PM
probs with libgmodules and libglib Jo_Nak Linux - Software 0 07-09-2003 01:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration