LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-02-2009, 05:05 AM   #1
ludo33
Member
 
Registered: Feb 2009
Posts: 119

Rep: Reputation: 16
Help installing eAccelerator


Hello,

I'm trying to install eAccelerator on Debian Lenny.
I followed the instructions at http://www.debianadmin.com/php-cache...tutorials.html and got as far as
./configure –enable-eaccelerator=shared –with-php-config=/usr/bin/php-config and got the result configure: error: invalid variable name: –enable-eaccelerator

Has anybody had any success in getting eAccelerator to work with Debian Lenny?

TYIA
 
Old 03-02-2009, 05:08 AM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,529

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
try
./configure --enable-eaccelerator
 
Old 03-02-2009, 06:36 AM   #3
ludo33
Member
 
Registered: Feb 2009
Posts: 119

Original Poster
Rep: Reputation: 16
Thanks...but

Hello,

Many thanks for your reply, that did something. Then I ran "make" as per instruction...got "make: command not found" guess I'm missing something from my installation.

Many Thanks.
 
Old 03-02-2009, 06:48 AM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,529

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Code:
apt-get install make
You probably also want to install
Code:
apt-get install build-essential linux-headers-`uname -r`
 
Old 03-02-2009, 07:12 AM   #5
ludo33
Member
 
Registered: Feb 2009
Posts: 119

Original Poster
Rep: Reputation: 16
Yep

That did the trick, thank you very much for your help. One last question, is there any merit in installing it as a Zend extention? Whatever that is!
 
Old 03-02-2009, 07:19 AM   #6
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Quote:
Originally Posted by ludo33 View Post
That did the trick, thank you very much for your help. One last question, is there any merit in installing it as a Zend extention? Whatever that is!
If you're building a web server or using a database like mysql, then it might be. I have lived a long and happy life without it
cheers,
jdk
 
Old 03-02-2009, 07:26 AM   #7
ludo33
Member
 
Registered: Feb 2009
Posts: 119

Original Poster
Rep: Reputation: 16
Hmm

Spoke too soon.

Put

xtension=”eaccelerator.so”
eaccelerator.shm_size=”16″
eaccelerator.cache_dir=”/tmp/eaccelerator”
eaccelerator.enable=”1″
eaccelerator.optimizer=”1″
eaccelerator.check_mtime=”1″
eaccelerator.debug=”0″
eaccelerator.filter=”"
eaccelerator.shm_max=”0″
eaccelerator.shm_ttl=”0″
eaccelerator.shm_prune_period=”0″
eaccelerator.shm_only=”0″
eaccelerator.compress=”1″
eaccelerator.compress_level=”9″

In my /etc/php/apache2/php.ini restarted apache and it gets changed to

extension=eaccelerator.so
eaccelerator.shm_size=163
eaccelerator.cache_dir=/tmp/eaccelerator
eaccelerator.enable=13
eaccelerator.optimizer=13
eaccelerator.check_mtime=13
eaccelerator.debug=03
eaccelerator.filter="
eaccelerator.shm_max=03
eaccelerator.shm_ttl=03
eaccelerator.shm_prune_period=03
eaccelerator.shm_only=03
eaccelerator.compress=13
eaccelerator.compress_level=93

It doesn't like the quotation marks!
 
Old 03-02-2009, 07:32 AM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,529

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
which php version are you using?
 
Old 03-02-2009, 07:35 AM   #9
ludo33
Member
 
Registered: Feb 2009
Posts: 119

Original Poster
Rep: Reputation: 16
oops

php5 sorry that should of been etc/php5/apache2/php.ini
 
Old 03-02-2009, 07:38 AM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,529

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
try add the " manually
it should give " not ″
 
Old 03-02-2009, 07:54 AM   #11
ludo33
Member
 
Registered: Feb 2009
Posts: 119

Original Poster
Rep: Reputation: 16
Why

Why oh why when I try to install something on debian that's not an apt-get do I end up in the $#~* ?

Edited with " and that seems ok now in the php.ini but trying the test page with
<?php
eaccelerator();
?> (after re-starting apache) and I get:

"Fatal error: Call to undefined function eaccelerator() in /var/www/test.php on line 1"
 
Old 03-02-2009, 08:05 AM   #12
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,529

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Did you do the "make install" after the "make" command ?
 
Old 03-02-2009, 09:15 AM   #13
ludo33
Member
 
Registered: Feb 2009
Posts: 119

Original Poster
Rep: Reputation: 16
Yep

I followed http://www.debianadmin.com/php-cache...tutorials.html religeously.

The only difference was the line ./configure –enable-eaccelerator=shared –with-php-config=/usr/bin/php-config which was changed to ./configure –enable-eaccelerator

Arggggghhh!
 
Old 03-02-2009, 09:27 AM   #14
ludo33
Member
 
Registered: Feb 2009
Posts: 119

Original Poster
Rep: Reputation: 16
Hmmm

./configure –enable-eaccelerator=shared –with-php-config=/usr/bin/php-config

I dont see a /usr/bin/php-config file but I do have a /usr/bin/php-config5. Should the line be ./configure –enable-eaccelerator=shared –with-php-config5=/usr/bin/php-config5 ?
 
Old 03-02-2009, 12:06 PM   #15
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,529

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Quote:
./configure -enable-eaccelerator=shared –with-php-config5=/usr/bin/php-config5
you could try, look for error messages.
If there are error messages, you will not be able to use make until the errors are gone.
then do
Code:
make
and
Code:
make install
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with eAccelerator jim.thornton Linux - Server 0 06-06-2008 09:20 PM
eaccelerator missing configure? ziggie216 Linux - Software 0 09-03-2006 12:55 PM
sessions in eaccelerator seshank Linux - Software 0 05-31-2006 01:45 AM
Installing the nvidia driver off the web site and installing rpm in ubuntu? darkhatter Ubuntu 3 02-19-2006 02:44 PM
eaccelerator problem I_AM Linux - Software 3 11-29-2005 01:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration