LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-28-2017, 11:26 PM   #1
plasticsalad
LQ Newbie
 
Registered: Dec 2017
Posts: 1

Rep: Reputation: Disabled
Question Help configuring postfix as a relay


Hello, i'm trying to get postfix installed on my debian desktop so that I can send automated emails to myself. But I can't seem to understand what a lot of the configuration means. I used this tutorial to set it up but it fails. I didn't use gmail though but I don't think that should be the issue.

The error log i get when i try sendmail is:

Code:
Dec 28 23:11:33 fortress postfix/qmgr[6119]: 1C58C61B14: from=<root@fortress.krypto>, size=280, nrcpt=1 (queue active)
Dec 28 23:11:47 fortress postfix/smtp[10817]: 1C58C61B14: to=<my-email-here@airmail.cc>, relay=mail.cock.li[185.100.85.212]:587, delay=52, delays=38/0.06/13/0.95, dsn=5.7.1, status=bounced (host mail.cock.li[185.100.85.212] said: 553 5.7.1 <root@fortress.krypto>: Sender address rejected: not owned by user my-email-here@airmail.cc (in reply to RCPT TO command))
Dec 28 23:11:50 fortress postfix/cleanup[10815]: 2186961B23: message-id=<20171229041150.2186961B23@fortress.krypto>
Dec 28 23:11:50 fortress postfix/qmgr[6119]: 2186961B23: from=<>, size=2430, nrcpt=1 (queue active)
Dec 28 23:11:50 fortress postfix/bounce[11480]: 1C58C61B14: sender non-delivery notification: 2186961B23
Dec 28 23:11:50 fortress postfix/qmgr[6119]: 1C58C61B14: removed
Dec 28 23:11:50 fortress postfix/local[11666]: 2186961B23: to=<user@fortress.krypto>, orig_to=<root@fortress.krypto>, relay=local, delay=0.07, delays=0.01/0.02/0/0.04, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Dec 28 23:11:50 fortress postfix/qmgr[6119]: 2186961B23: removed
And according to this, i needed to set those two maps. But it failed again and i purged postfix and tried to configure it again.

Here is my /etc/postfix/main.cf

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# See http://www.postfix.org/COMPATIBILITY_README.html -- default to 2 on
# fresh installs.
compatibility_level = 2

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
myhostname = fortress.krypto
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = $myhostname, fortress.krypto, localhost.krypto, , localhost
relayhost = [mail.cock.li]:587
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all

# Enable SASL authentication
smtp_sasl_auth_enable = yes
# Disallow methods that allow anonymous authentication
smtp_sasl_security_options = noanonymous
# Location of sasl_passwd
smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd
# Enable STARTTLS encryption
smtp_tls_security_level = encrypt
# Location of CA certificates
smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
If someone could help me, that would be mean a lot!

Notes:
- myhostname: fortress.krypto - this is just the default value that debconf had when i installed. fortress is my hostname. Should this be changed to something else?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
554 5.7.1 Relay access denied Postfix Open Relay kryspek Linux - Software 5 04-26-2017 09:35 AM
Postfix Relay Getting Spammed Bad -- But no open relay... ihod2008 Linux - Server 1 07-26-2008 09:24 PM
Postfix as a mail relay (getting relay access denied) hypexr Linux - Software 3 09-13-2005 08:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration