LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-05-2003, 02:26 PM   #1
shuttleX
LQ Newbie
 
Registered: Jun 2003
Posts: 2

Rep: Reputation: 0
Help CGI won't run under Apache


Ok, I'm kinda new to this so here is my dilemma. I have RedHat 9.0 I installed it with Apache in the installation. I am trying to get a Perl script to run. This script has successfully run on a Solaris machine. However whenever I submit the form that calls the script on this computer, I get error 500 Internal server error. The log is only telling me that there is a problem with my header files. I checked the permissions... nothing wrong there everyone has execute rights. Can someone please help?!?!?!? thanks in advance.
 
Old 06-05-2003, 02:31 PM   #2
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Did you install the perl modules for apache too? Try the latest patched ones from RedHat.
Isnt there a few tests scripts that you can try to run to check everything's setup? (I'm just starting to install an apache server myself)
 
Old 06-05-2003, 03:37 PM   #3
shuttleX
LQ Newbie
 
Registered: Jun 2003
Posts: 2

Original Poster
Rep: Reputation: 0
I have Perl installed on this machine... I can run Hello World!! I only have problems when using perl with apache.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
does apache support cgi scripts and how to run them abhis_mail2002 Fedora 3 03-15-2005 05:37 AM
Cant run CGI scripts on Apache! mylo2003 Linux - General 5 11-09-2004 10:22 AM
how to configure apache in Suse 9.1 t run cgi programmes written in python drako123 Linux - Software 0 08-21-2004 08:27 AM
Apache 2.0.43 will not run cgi scripts RobbieRoy Linux - Networking 5 09-04-2003 03:56 PM
apache v2.0.44 + cgi ; securing cgi-support in apache markus1982 Linux - General 0 01-20-2003 02:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration